git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v3] Simplify handling of setup_git_directory_gently() failure cases.

From
Junio C Hamano <gitster@pobox.com>
Date
Jan 3, 2019, 18:09 UTC
Message-ID
<xmqqy381haup.fsf@gitster-ct.c.googlers.com>
In-Reply-To
<20190103051432.GE20047@sigill.intra.peff.net>
>Subject: Re: [PATCH v3] Simplify handling of setup_git_directory_gently() failure cases.
Perhaps
	Subject: setup: simplify setup_git_directory_gently() failure cases
to clarify which part of the entire world this patch is touching.
Jeff King <peff@peff.net> writes:
Show 14 quoted lines
> This patch isn't _too_ big, so I don't think it's worth the effort at
> this point for this particular case, but just something to think about
> for the future. A series around this topic would probably be something
> like:
>
>   1: drop the useless chdir and fold setup_nongit() into the main
>      function
>
>   2: stop doing the early return from HIT_MOUNT_POINT, and treat it just
>      like HIT_CEILING (and drop the useless strbuf release)
>
>   3: treat GIT_DIR_NONE as a BUG
>
>   4: rearrange the nongit logic at the end of the function for clarity

Yeah, that organization does make sense. And I agree with your rule of thumb to use the length and complexity of the log message to judge if a single step is getting too big.

Show 5 quoted lines
> We usually avoid "//" comments, even for single lines (though that is
> perhaps superstition at this point, as we've started to embrace several
> other C99-isms). IMHO this particular comment is not even really
> necessary, as the whole conditional is suitably short and obvious after
> your refactor.

FWIW "git grep" for // seems to show that we reserve use of // inside commented out code samples.

I also agree the comments behind // in this patch are probably unneeded.

Show 14 quoted lines
>
>> @@ -1132,7 +1142,10 @@ const char *setup_git_directory_gently(int *nongit_ok)
>>  	 * the user has set GIT_DIR.  It may be beneficial to disallow bogus
>>  	 * GIT_DIR values at some point in the future.
>>  	 */
>> -	if (startup_info->have_repository || getenv(GIT_DIR_ENVIRONMENT)) {
>> +	if (// GIT_DIR_EXPLICIT, GIT_DIR_DISCOVERED, GIT_DIR_BARE
>> +	    startup_info->have_repository ||
>> +	    // GIT_DIR_EXPLICIT
>> +	    getenv(GIT_DIR_ENVIRONMENT)) {
>
> Same "//" style issue as above. I'm not sure how much value there is in
> repeating the GIT_DIR_* cases here, as they're likely to grow out of
> sync with the switch() statement above.

It is unclear to me if the original code is doing the right thing under one condition, and this patch does not seem to change the behaviour.

What happens if GIT_DIR environment is set to an invalid path and nongit_ok is non-NULL? setup_explicit_git_dir() would have assigned 1 to *nongit_ok, so have_repository is false at this point.

We enter the if() statement in such a case, and end up calling setup_git_env(gitdir) using the bogus path that is not pointing at a repository. We leave have_repository to be false but the paths recorded in the_repository by setup_git_env() would all point at bogus places.

> At first I thought this could all be folded into the "else" clause of
> the conditional above (which would make the logic much easier to
> follow), but that wouldn't cover the case of GIT_DIR=/bogus, which is
> what that getenv() is trying to handle here.
Yes, but should GIT_DIR=/bogus even be touching the_repository?  

It is a separate clean-up and does not affect the validity of this simplification patchd, so I agreee with ...

> So I think this is the best we can do for now.
Thanks.
Previous: Jeff KingNext: Jeff King
Message 16 of 19 in “Simplify handling of setup_git_directory_gently() failure cases.”
  1. Simplify handling of setup_git_directory_gently() failure cases.Erin Dahlgren, Dec 13, 2018
  2. Johannes SchindelinDec 14, 2018
  3. Erin DahlgrenDec 16, 2018
  4. Simplify handling of setup_git_directory_gently() failure cases.Erin Dahlgren, Dec 16, 2018
  5. Johannes SchindelinDec 18, 2018
  6. Erin DahlgrenDec 18, 2018
  7. Jeff KingDec 18, 2018
  8. Erin DahlgrenDec 18, 2018
  9. Jeff KingDec 19, 2018
  10. Junio C HamanoDec 26, 2018
  11. Jeff KingDec 27, 2018
  12. Erin DahlgrenDec 27, 2018
  13. Jeff KingJan 3, 2019
  14. Simplify handling of setup_git_directory_gently() failure cases.Erin Dahlgren, Dec 27, 2018
  15. Jeff KingJan 3, 2019
  16. Junio C HamanoJan 3, 2019
  17. Jeff KingJan 4, 2019
  18. Erin DahlgrenJan 5, 2019
  19. Jeff KingJan 6, 2019

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.