"What's cooking" interim report
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Apr 9, 2025, 23:10 UTC
- Message-ID
- <xmqqy0w9orsn.fsf@gitster.g>
Since the issue #02 of this month, a handful of topics have been picked up, a few topics have been replaced by their newer iterations, a topic that is already in 'next' gained an additional commit on top, and a topic got its description extended.
-------------------------------------------------- Born topics
[New Topics]
* kn/bundle-dedup-optim (2025-04-08) 2 commits - bundle: fix non-linear performance scaling with refs - t6020: test for duplicate refnames in bundle creation
Optimize the code to dedup references recorded in a bundle file.
Will merge to 'next'? source: <20250408-488-generating-bundles-with-many-references-has-non-linear-performance-v2-0-0802fc36a23d@gmail.com>
* kn/meson-hdr-check (2025-04-08) 4 commits - meson: add support for 'headers-check' - meson: move headers definition from 'contrib/coccinelle' - coccinelle: meson: rename variables to be more specific - Merge branch 'es/meson-build-skip-coccinelle' into kn/meson-hdr-check
Add an equivalent to "make hdr-check" target to meson based builds.
Getting there. cf. <xmqqsemiuwhx.fsf@gitster.g> source: <20250408-505-wire-up-sparse-via-meson-v1-0-17476e5cea3f@gmail.com>
* ps/object-file-cleanup (2025-04-08) 10 commits - object-store: merge "object-store-ll.h" and "object-store.h" - object-store: remove global array of cached objects - object: split out functions relating to object store subsystem - object-file: split out functions relating to index subsystem - object-file: split up concerns of `HASH_*` flags - object-file: split out functions relating to object store subsystem - object-file: move `xmmap()` into "wrapper.c" - object-file: move `git_open_cloexec()` to "compat/open.c" - object-file: move `safe_create_leading_directories()` into "dir.c" - Merge branch 'ps/object-wo-the-repository' into ps/object-file-cleanup (this branch uses ps/object-wo-the-repository.)
Code clean-up.
Will merge to 'next'? cf. <xmqqsemiteot.fsf@gitster.g> cf. <CABPp-BFv_WGVUexyQBHkCcyO0N+UQCcJ3eM9Oh6bP_ZCUkaxLw@mail.gmail.com> source: <20250408-pks-split-object-file-v1-0-f1fd50191143@pks.im>
* ab/environment-clean-header (2025-04-09) 1 commit - environment.h: remove unused variables
Code clean-up.
Will merge to 'next'. source: <2c547567-2b72-476c-9fc5-71cac050fa15@gmail.com>
* cj/refname-avail-check-optim-typofix (2025-04-09) 1 commit - refs: fix duplicated word in comment
Comment fix.
Will merge to 'next'. source: <pull.1940.v2.git.git.1743857867327.gitgitgadget@gmail.com>
* dd/sparse-glibc-workaround (2025-04-09) 1 commit - sparse: ignore warning from new glibc headers
Squelch false-positive from sparse.
Will merge to 'next'. source: <a667da3985a0fe943cc0ff6ee8513d731d75a299.1721171853.git.congdanhqx@gmail.com>
* js/ci-github-update-ubuntu (2025-04-09) 1 commit - ci: upgrade `sparse` to supported build agents
Adjust to the deprecation of use of Ubuntu 20.04 GitHub Actions CI.
Will merge to 'next'. source: <77f82414-261c-d2bc-f911-ed3d4b06c86e@gmx.de>
* ps/refname-avail-check-optim (2025-04-09) 1 commit - refs/packed: fix BUG when seeking refs with UTF-8 characters
Incorrect sorting of refs with bytes with high-bit set on platforms with signed char led to a BUG, which has been corrected.
Will merge to 'next'. cf. <20250404205740.GA780449@coredump.intra.peff.net> source: <20250404-b4-pks-packed-backend-seek-with-utf8-v1-1-6ceb694e3bd7@pks.im>
* rj/build-tweaks (2025-04-09) 13 commits - config.mak.uname: set CSPRNG_METHOD to getrandom on Linux - config.mak.uname: add arc4random to the cygwin build - config.mak.uname: add sysinfo() configuration for cygwin - builtin/gc.c: correct RAM calculation when using sysinfo - config.mak.uname: add clock_gettime() to the cygwin build - config.mak.uname: add HAVE_GETDELIM to the cygwin section - config.mak.uname: only set NO_REGEX on cygwin for v1.7 - config.mak.uname: add a note about NO_STRLCPY for Linux - Makefile: remove NEEDS_LIBRT build variable - meson.build: set default help format to html on windows - meson.build: only set build variables for non-default values - Makefile: only set some BASIC_CFLAGS when RUNTIME_PREFIX is set - meson.build: remove -DCURL_DISABLE_TYPECHECK
Various build tweaks, including CSPRNG selection on some platforms.
Comments? source: <cover.1743859985.git.ramsay@ramsayjones.plus.com>
-------------------------------------------------- Other topics that had seen changes.
[Cooking]
* pb/status-rebase-fixes (2025-03-28) 4 commits - wt-status: suggest 'git rebase --continue' to conclude 'merge' instruction - wt-status: also abbreviate 'merge' and 'fixup -C' lines during rebase - SQUASH??? - <CAPig+cS92W_gYuNsaTvQxiP3xBK7Wpg0__uVkgAU1x0OFJUZgQ@mail.gmail.com> - rebase -r: do create merge commit after empty resolution - A few fixes around "git status" while "git rebase" is running. + A few fixes around "git status" while "git rebase" is running, + plus a corner case bug fix for "git rebase -r". - Comments? It probably deserves a clarifying reroll. + Expecting a (small and hopefully final) clarifying reroll. cf. <c2f93d99-2f4d-ee6d-7087-42320c6df0f2@gmx.de> + cf. <e9700234-324d-dc63-d91e-9b8f36fabc79@gmail.com> source: <pull.1897.git.1743181401.gitgitgadget@gmail.com>
-* ua/update-update-server-info (2025-03-29) 1 commit +* ua/update-update-server-info (2025-04-08) 1 commit - builtin/update-server-info: remove unnecessary if statement - Expecting a (hopefully minor and final) reroll. - cf. <xmqqa58snf9c.fsf@gitster.g> - source: <20250329120327.105925-2-usmanakinyemi202@gmail.com> + Code simplification. + + Will merge to 'next'. + source: <20250407195850.299348-2-usmanakinyemi202@gmail.com>
-* en/merge-recursive-debug (2025-04-07) 8 commits
+* en/merge-recursive-debug (2025-04-08) 8 commits
- builtin/{merge,rebase,revert}: remove GIT_TEST_MERGE_ALGORITHM
- tests: remove GIT_TEST_MERGE_ALGORITHM and test_expect_merge_algorithm
- merge-recursive.[ch]: thoroughly debug these
- merge, sequencer: switch recursive merges over to ort
- sequencer: switch non-recursive merges over to ort
- merge-ort: enable diff-algorithms other than histogram
- builtin/merge-recursive: switch to using merge_ort_generic()
- checkout: replace merge_trees() with merge_ort_nonrecursive()
- Expecting a reroll.
- cf. <CABPp-BGN2JCt9BJ0wQqtgNLhD6Qf19PMzYWpjgpJ6O2OcyRCXg@mail.gmail.com>
- source: <pull.1898.v2.git.1743891374.gitgitgadget@gmail.com>
+ Remove remnants of the recursive merge strategy backend, which was
+ superseded by the ort merge strategy.
+
+ Will merge to 'next'.
+ source: <pull.1898.v3.git.1744127322.gitgitgadget@gmail.com>-* jk/fetch-follow-remote-head-fix (2025-03-18) 3 commits +* jk/fetch-follow-remote-head-fix (2025-04-09) 4 commits + - fetch: make set_head() call easier to read (merged to 'next' on 2025-04-07 at ba5ac342a5) + fetch: don't ask for remote HEAD if followRemoteHEAD is "never" + fetch: only respect followRemoteHEAD with configured refspecs + Merge branch 'jk/fetch-ref-prefix-cleanup' into jk/fetch-follow-remote-head-fix "git fetch [<remote>]" with only the configured fetch refspec should be the only thing to update refs/remotes/<remote>/HEAD, but the code was overly eager to do so in other cases. - Will merge to 'master'. + Will merge to 'next' and then to 'master'. cf. <Z9n7myvpnDOWFWqt@nand.local> source: <20250318053905.GA2051217@coredump.intra.peff.net>