Re: [PATCH 1/3] tag: use skip_prefix instead of magic numbers
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jul 11, 2014, 22:44 UTC
- Message-ID
- <xmqqwqbj1poi.fsf@gitster.dls.corp.google.com>
- In-Reply-To
- <1405114724-23829-1-git-send-email-jacob.e.keller@intel.com>
Jacob Keller <jacob.e.keller@intel.com> writes:
Show 35 quoted lines
> From: Jeff King <peff@peff.net>
>
> Make the parsing of the --sort parameter more readable by having
> skip_prefix keep our pointer up to date.
>
> Signed-off-by: Jeff King <peff@peff.net>
> Signed-off-by: Jacob Keller <jacob.e.keller@intel.com>
> ---
> builtin/tag.c | 14 ++++----------
> 1 file changed, 4 insertions(+), 10 deletions(-)
>
> diff --git a/builtin/tag.c b/builtin/tag.c
> index ef765563388c..7ccb6f3c581b 100644
> --- a/builtin/tag.c
> +++ b/builtin/tag.c
> @@ -524,18 +524,12 @@ static int parse_opt_sort(const struct option *opt, const char *arg, int unset)
> int *sort = opt->value;
> int flags = 0;
>
> - if (*arg == '-') {
> + if (skip_prefix(arg, "-", &arg))
> flags |= REVERSE_SORT;
> - arg++;
> - }
> - if (starts_with(arg, "version:")) {
> +
> + if (skip_prefix(arg, "version:", &arg) || skip_prefix(arg, "v:", &arg))
> *sort = VERCMP_SORT;
> - arg += 8;
> - } else if (starts_with(arg, "v:")) {
> - *sort = VERCMP_SORT;
> - arg += 2;
> - } else
> - *sort = STRCMP_SORT;
> +By losing "*sort = STRCMP_SORT", the version after this patch would stop clearing what is pointed by opt->value, so
git tag --sort=v:refname --sort=refname
would no longer implement the "last one wins" semantics, no?
Am I misreading the patch? I somehow thought Peff's original was clearing the variable...
> if (strcmp(arg, "refname"))
> die(_("unsupported sort specification %s"), arg);
> *sort |= flags;