git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH/RFC v2 0/7] Introduce new commands switch-branch and checkout-files

From
Junio C Hamano <gitster@pobox.com>
Date
Nov 29, 2018, 06:14 UTC
Message-ID
<xmqqwoowo1fk.fsf@gitster-ct.c.googlers.com>
In-Reply-To
<CAPL8ZivFJXQw=yLXjOPxsjabwN5XAP_qe0LK3sODO4NkgCjZag@mail.gmail.com>
Stefan Xenos <sxenos@google.com> writes:
> So - IMO - detaching should always be an explicit action. Some options
> that occur to me:
>
> git switch-branch --detach

That is the most obvious way to spell it, and it is why we have "git checkout --detach". If we were to split one half of "checkout" into "switch-branch", I would support the idea to make switch-branch only take a branch name and nothing else, allow it to take any commit-ish to detach the HEAD at that commit in the history graph with the --detach option". I also do not think anybody minds explaining the resulting state to be "on an unnamed branch" (or is it "the" unnamed branch? Given that HEAD@{} reflog is a singleton, perhaps the right mental model is that there is only one unnamed branch per worktree).

> git detach

The detached HEAD state is not all that special to deserve a separate command. After all, all history growing commands like "commit", "cherry-pick", "rebase", "merge", etc. work the same way on the unnamed branch.

> git switch-branch HEAD

I do not think this one is acceptable. "git checkout HEAD" does not detach but works as if you said "git checkout master" (when on the 'master' branch). And you do not want "git switch-branch HEAD^0" to be that explicit way to tell Git to detach the HEAD as that will take us back to square one ("git checkout HEAD^0" is the more concise and time-honored way to say "git checkout --detach HEAD").

Previous: Stefan Xenos
Message 110 of 110 in “checkout: print something when checking out paths”
  1. checkout: print something when checking out pathsNguyễn Thái Ngọc Duy, Nov 10, 2018
  2. Junio C HamanoNov 12, 2018
  3. Duy NguyenNov 12, 2018
  4. Junio C HamanoNov 12, 2018
  5. Ævar Arnfjörð BjarmasonNov 19, 2018
  6. Duy NguyenNov 19, 2018
  7. Junio C HamanoNov 20, 2018
  8. [RFC] Introduce two new commands, switch-branch and restore-pathsDuy Nguyen, Nov 20, 2018
  9. Thomas GummererNov 25, 2018
  10. Junio C HamanoNov 26, 2018
  11. Duy NguyenNov 26, 2018
  12. Ævar Arnfjörð BjarmasonNov 26, 2018
  13. Duy NguyenNov 26, 2018
  14. Stefan BellerNov 26, 2018
  15. Junio C HamanoNov 27, 2018
  16. 0/7 Introduce new commands switch-branch and checkout-filesNguyễn Thái Ngọc Duy, Nov 27, 2018
  17. 1/7 parse-options: allow parse_options_concat(NULL, options)Nguyễn Thái Ngọc Duy, Nov 27, 2018
  18. Stefan BellerNov 27, 2018
  19. Duy NguyenNov 28, 2018
  20. Junio C HamanoNov 28, 2018
  21. 2/7 checkout: make "opts" in cmd_checkout() a pointerNguyễn Thái Ngọc Duy, Nov 27, 2018
  22. 5/7 checkout: split options[] array in three piecesNguyễn Thái Ngọc Duy, Nov 27, 2018
  23. Junio C HamanoNov 29, 2018
  24. 6/7 checkout: split into switch-branch and checkout-filesNguyễn Thái Ngọc Duy, Nov 27, 2018
  25. Junio C HamanoNov 28, 2018
  26. Duy NguyenNov 28, 2018
  27. Stefan BellerNov 28, 2018
  28. Duy NguyenNov 28, 2018
  29. Junio C HamanoNov 29, 2018
  30. Stefan XenosNov 28, 2018
  31. Stefan XenosNov 28, 2018
  32. Stefan XenosNov 28, 2018
  33. Junio C HamanoNov 29, 2018
  34. Duy NguyenNov 29, 2018
  35. Duy NguyenNov 29, 2018
  36. Stefan BellerNov 29, 2018
  37. Duy NguyenNov 29, 2018
  38. Stefan XenosNov 29, 2018
  39. 4/7 checkout: move dwim_new_local_branch to checkout_optsNguyễn Thái Ngọc Duy, Nov 27, 2018
  40. Stefan BellerNov 27, 2018
  41. 7/7 Suggest other commands instead of "git checkout"Nguyễn Thái Ngọc Duy, Nov 27, 2018
  42. Junio C HamanoNov 28, 2018
  43. Duy NguyenNov 28, 2018
  44. Junio C HamanoNov 29, 2018
  45. 3/7 checkout: move 'confict_style' to checkout_optsNguyễn Thái Ngọc Duy, Nov 27, 2018
  46. Stefan BellerNov 27, 2018
  47. Duy NguyenNov 28, 2018
  48. Duy NguyenNov 28, 2018
  49. Stefan BellerNov 28, 2018
  50. Duy NguyenNov 29, 2018
  51. Stefan BellerDec 3, 2018
  52. Junio C HamanoNov 30, 2018
  53. 00/14 Introduce new commands switch-branch and restore-filesNguyễn Thái Ngọc Duy, Nov 29, 2018
  54. 01/14 git-checkout.txt: fix one syntax lineNguyễn Thái Ngọc Duy, Nov 29, 2018
  55. 03/14 checkout: factor out some code in parse_branchname_arg()Nguyễn Thái Ngọc Duy, Nov 29, 2018
  56. 04/14 checkout: make "opts" in cmd_checkout() a pointerNguyễn Thái Ngọc Duy, Nov 29, 2018
  57. 05/14 checkout: move 'confict_style' and 'dwim_..' to checkout_optsNguyễn Thái Ngọc Duy, Nov 29, 2018
  58. 06/14 checkout: split options[] array in three piecesNguyễn Thái Ngọc Duy, Nov 29, 2018
  59. 08/14 switch-branch: better names for -b and -BNguyễn Thái Ngọc Duy, Nov 29, 2018
  60. 09/14 switch-branch: stop accepting pathspecNguyễn Thái Ngọc Duy, Nov 29, 2018
  61. 10/14 switch-branch: reject "do nothing" caseNguyễn Thái Ngọc Duy, Nov 29, 2018
  62. 11/14 switch-branch: only allow explicit detached HEADNguyễn Thái Ngọc Duy, Nov 29, 2018
  63. Eckhard MaaßMar 10, 2019
  64. Duy NguyenMar 11, 2019
  65. 12/14 restore-files: take tree-ish from --from option insteadNguyễn Thái Ngọc Duy, Nov 29, 2018
  66. 13/14 restore-files: make pathspec mandatoryNguyễn Thái Ngọc Duy, Nov 29, 2018
  67. 14/14 doc: promote "git switch-branch" and "git restore-files"Nguyễn Thái Ngọc Duy, Nov 29, 2018
  68. 07/14 checkout: split into switch-branch and restore-filesNguyễn Thái Ngọc Duy, Nov 29, 2018
  69. Elijah NewrenDec 4, 2018
  70. Junio C HamanoDec 4, 2018
  71. Duy NguyenDec 4, 2018
  72. Elijah NewrenDec 4, 2018
  73. Duy NguyenDec 4, 2018
  74. Junio C HamanoDec 5, 2018
  75. Elijah NewrenDec 5, 2018
  76. Junio C HamanoDec 5, 2018
  77. Junio C HamanoDec 5, 2018
  78. Elijah NewrenDec 5, 2018
  79. 02/14 git-checkout.txt: split detached head section outNguyễn Thái Ngọc Duy, Nov 29, 2018
  80. Ævar Arnfjörð BjarmasonNov 29, 2018
  81. Ævar Arnfjörð BjarmasonNov 29, 2018
  82. Dan FabulichNov 29, 2018
  83. Dan FabulichNov 30, 2018
  84. Duy NguyenNov 30, 2018
  85. Duy NguyenNov 30, 2018
  86. Junio C HamanoNov 30, 2018
  87. Ævar Arnfjörð BjarmasonNov 30, 2018
  88. Duy NguyenNov 30, 2018
  89. Junio C HamanoNov 30, 2018
  90. Duy NguyenNov 30, 2018
  91. Junio C HamanoNov 30, 2018
  92. Thomas GummererDec 2, 2018
  93. Junio C HamanoDec 2, 2018
  94. Elijah NewrenDec 4, 2018
  95. Duy NguyenDec 4, 2018
  96. Elijah NewrenDec 4, 2018
  97. Duy NguyenDec 4, 2018
  98. Elijah NewrenDec 4, 2018
  99. Duy NguyenDec 4, 2018
  100. Eric SunshineDec 4, 2018
  101. checkout: print something when checking out pathsNguyễn Thái Ngọc Duy, Nov 13, 2018
  102. Junio C HamanoNov 14, 2018
  103. Duy NguyenNov 14, 2018
  104. Junio C HamanoJan 28, 2019
  105. Duy NguyenJan 29, 2019
  106. 0/2 nd/checkout-noisy updatesNguyễn Thái Ngọc Duy, Feb 6, 2019
  107. 1/2 checkout: update count-checkouts messagesNguyễn Thái Ngọc Duy, Feb 6, 2019
  108. 2/2 checkout: count and print -m paths separatelyNguyễn Thái Ngọc Duy, Feb 6, 2019
  109. Stefan XenosNov 28, 2018
  110. Junio C HamanoNov 29, 2018

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.