Re: [PATCH] clone: add `--shallow-submodules` flag
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Apr 25, 2016, 22:37 UTC
- Message-ID
- <xmqqvb35iabx.fsf@gitster.mtv.corp.google.com>
- In-Reply-To
- <CAGZ79kbPcefodLd4Jt4tvJJmHZXJGe-AMEgzREWZiUvNeciFSQ@mail.gmail.com>
Stefan Beller <sbeller@google.com> writes:
> I agree. How about `currentdir`, `testdir` or `testtop` instead? > That is slightly longer than `D`, `here` or `top`, but is slightly more > informative. $TRASH would also work for me.
I would not be happy to see a patch that adds yet another variable that is never used so far, like currentdir, testdir, or testtop.
Among the ones I found that are already in use, $here is probably my favourite, because it does _not_ have to be set to the top; it just says "this is the directory my main focus is in".
Having said that, personally, I find $D (as long as D is in capital) is distinctive and descriptive enough.