Re: [PATCH v2] l10n: reformat some localized strings for v2.23.0
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Aug 5, 2019, 18:49 UTC
- Message-ID
- <xmqqv9vbmoqd.fsf@gitster-ct.c.googlers.com>
- In-Reply-To
- <20190803234522.GA5417@sigill.intra.peff.net>
Jeff King <peff@peff.net> writes:
Show 5 quoted lines
>> OPT_STRING('s', "source", &opts.from_treeish, "<tree-ish>",
>> - N_("where the checkout from")),
>> + N_("where the checkout is from")),
>
> I think your original "where to checkout from" is better.Would we even want to do s/where/which tree-ish/?
Show 16 quoted lines
> translators, but note that the output will be different. The original > would be something like: > > warning: Fetch normally indicates... > warning: To re-enable... > > where now we'd get: > > warning: Fetch normally indicates... > check has been disabled... > or run 'git config... > > which might be a bit harder to read because the wrapped lines lose the > prefix. For advise() we nicely pick out the newlines and prefix each > line individually, but warning(), error(), etc, don't do that. Maybe > they should.
Yeah, I'd be surprised that nobody thought of doing that, so perhaps somebody tried and failed with a possible fallout. I do not offhand see any downside of teaching them to do the prefixing.
For existing multi-line warnings that uses a single call to warning(), I think the preparer of the message manually indents the second and subsequent line by a run of SPs to match the screen width of "warning:" prefix (and expect translators to do the same with their language), and we need to get rid of that kind of "hack" when we insert a middle layer between *_builtin() and vreportf() to do the line chomping to produce output similar to advise() code.
> That's too big for this late in the -rc cycle, I think.
Agreed. Thanks.