Re: [PATCH v1] preload-index: update GIT_FORCE_PRELOAD_TEST support
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Sep 13, 2018, 21:39 UTC
- Message-ID
- <xmqqtvmtdqkx.fsf@gitster-ct.c.googlers.com>
- In-Reply-To
- <20180913180054.29720-1-benpeart@microsoft.com>
Ben Peart <benpeart@microsoft.com> writes:
Show 6 quoted lines
> Rename GIT_FORCE_PRELOAD_TEST to GIT_TEST_PRELOAD for consistency with the > other GIT_TEST_ special setups and properly document its use. > > Signed-off-by: Ben Peart <Ben.Peart@microsoft.com> > --- >
Among the two unrelated changes that are not mentioned in the proposed log message, the change to the test to use sane_unset is probably OK, but replacing a call to getenv() with git_env_bool() without making sure necessary header file(s) are included would break the build.
I _think_ config.h is the header to include; I didn't try it, though.
Thanks.
Show 55 quoted lines
> Notes:
> Base Ref: v2.19.0
> Web-Diff: https://github.com/benpeart/git/commit/dcd201b920
> Checkout: git fetch https://github.com/benpeart/git git-test-preload-v1 && git checkout dcd201b920
>
> preload-index.c | 2 +-
> t/README | 3 +++
> t/t7519-status-fsmonitor.sh | 4 ++--
> 3 files changed, 6 insertions(+), 3 deletions(-)
>
> diff --git a/preload-index.c b/preload-index.c
> index 71cd2437a3..cc8a7333c2 100644
> --- a/preload-index.c
> +++ b/preload-index.c
> @@ -84,7 +84,7 @@ static void preload_index(struct index_state *index,
> return;
>
> threads = index->cache_nr / THREAD_COST;
> - if ((index->cache_nr > 1) && (threads < 2) && getenv("GIT_FORCE_PRELOAD_TEST"))
> + if ((index->cache_nr > 1) && (threads < 2) && git_env_bool("GIT_TEST_PRELOAD", 0))
> threads = 2;
> if (threads < 2)
> return;
> diff --git a/t/README b/t/README
> index 9028b47d92..73fb09560f 100644
> --- a/t/README
> +++ b/t/README
> @@ -319,6 +319,9 @@ GIT_TEST_OE_DELTA_SIZE=<n> exercises the uncomon pack-objects code
> path where deltas larger than this limit require extra memory
> allocation for bookkeeping.
>
> +GIT_TEST_PRELOAD=<boolean> exercises the preload-index code path by
> +overriding the minimum number of cache entries required per thread.
> +
> Naming Tests
> ------------
>
> diff --git a/t/t7519-status-fsmonitor.sh b/t/t7519-status-fsmonitor.sh
> index 756beb0d8e..9b703d49b5 100755
> --- a/t/t7519-status-fsmonitor.sh
> +++ b/t/t7519-status-fsmonitor.sh
> @@ -245,9 +245,9 @@ do
> git config core.preloadIndex $preload_val &&
> if test $preload_val = true
> then
> - GIT_FORCE_PRELOAD_TEST=$preload_val; export GIT_FORCE_PRELOAD_TEST
> + GIT_TEST_PRELOAD=$preload_val; export GIT_TEST_PRELOAD
> else
> - unset GIT_FORCE_PRELOAD_TEST
> + sane_unset GIT_TEST_PRELOAD
> fi
> '
>
>
> base-commit: 1d4361b0f344188ab5eec6dcea01f61a3a3a1670