Re: [PATCH 2/2] dir: improve naming of oid_stat fields in two structs
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Mar 16, 2020, 18:35 UTC
- Message-ID
- <xmqqo8sw87xj.fsf@gitster.c.googlers.com>
- In-Reply-To
- <xmqqsgi8882t.fsf@gitster.c.googlers.com>
Junio C Hamano <gitster@pobox.com> writes:
Show 13 quoted lines
> The potential for confusion with "path to these files" is real, I > would think, so they may benefit from some prefix. > > But instead of basing the prefix on their type, can we name it after > what this struct holds about the excludes file, and what the data > the struct holds is used for? Is "oidst" something that conveys it > well to the readers of the code? > ... > In a sense, this struct is a pared down version of cache_entry that > keeps the filesystem stat data to allow us quickly find if the path > was modified, and also lets us know if two contents are the same > without comparing bytes. It is a mechanism for us to tell validity > of our cached data. "struct path_validity" perhaps? I dunno.
I think "path_validity", while it probably is much better than "oid_stat", is a horrible name for the struct, so I'd welcome suggestions from third-party ;-)
But I think renaming "ss_info_exclude" to "info_exclude_validity" (or any name that talks about "info/exclude" and "validity") would be a vast improvement, regardless of what the struct is called.