Re: [PATCH v2] safe_create_leading_directories(): on Windows, \ can separate path components
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jan 21, 2014, 19:35 UTC
- Message-ID
- <xmqqmwipuo00.fsf@gitster.dls.corp.google.com>
- In-Reply-To
- <CAHGBnuMmutYqwZNw+VoZi=R_LaS_fowZrqaU2+JMYN53q6XQ2Q@mail.gmail.com>
Sebastian Schuberth <sschuberth@gmail.com> writes:
Show 13 quoted lines
> On Sun, Jan 19, 2014 at 12:40 AM, Michael Haggerty <mhagger@alum.mit.edu> wrote: > >> This patch applies on top of v3 of mh/safe-create-leading-directories. >> >> The only logical change from Sebastian's patch is that this version >> restores the original slash character rather than always restoring it >> to '/' (as suggested by Junio). > > Thanks Michael. This is very similar to Junio's current merge conflict > resultion in pu between your original series and my patch (c2fec83). I > like this patch of yours slightly better, however, as it uses a > "while" instead of a "for" loop and the more conclusive > "slash_character" than the "was_slash" variable name.
Yeah, I agree this patch that uses more descriptive names is a much more desirable end-result than the tentative merge in 'pu'.