Re: What's cooking in git.git (Jul 2020, #06; Thu, 30)
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jul 31, 2020, 01:27 UTC
- Message-ID
- <xmqqk0yk5v8y.fsf@gitster.c.googlers.com>
- In-Reply-To
- <20200731010307.GE240563@coredump.intra.peff.net>
Jeff King <peff@peff.net> writes:
Show 23 quoted lines
> On Thu, Jul 30, 2020 at 04:47:04PM -0700, Junio C Hamano wrote: > >> * jk/strvec (2020-07-28) 11 commits >> - strvec: rename struct fields >> - strvec: drop argv_array compatibility layer >> - strvec: update documention to avoid argv_array >> - strvec: fix indentation in renamed calls >> - strvec: convert remaining callers away from argv_array name >> - strvec: convert more callers away from argv_array name >> - strvec: convert builtin/ callers away from argv_array name >> - quote: rename sq_dequote_to_argv_array to mention strvec >> - strvec: rename files from argv-array to strvec >> - argv-array: rename to strvec >> - argv-array: use size_t for count and alloc >> >> The argv_array API is useful for not just managing argv but any >> "vector" (NULL-terminated array) of strings, and has seen adoption >> to a certain degree. It has been renamed to "strvec" to reduce the >> barrier to adoption. >> >> Will merge to 'next'. > > Do we want to do the s/items/v/ thing before it gets merged to next?
I do want to get rid of that items[] thing. An array with a plural name that is accessed one element at a time a lot more often than referred to as a collection as a whole is simply stupid.
Show 5 quoted lines
> I already posted a replacement top patch in the thread: > > https://lore.kernel.org/git/20200729003720.GA1653374@coredump.intra.peff.net/ > > and I don't think anything else needed a re-roll.
I missed that one. Will replace and adjust the conflict resolution but I'll have to wait for my attention/focus to be recharged before doing so.
Thanks for reminding.