Re: automerge implementation ideas for Windows
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jan 21, 2021, 22:50 UTC
- Message-ID
- <xmqqk0s5c3bv.fsf@gitster.c.googlers.com>
- In-Reply-To
- <20210120232447.GA35105@ellen>
Seth House <seth@eseth.com> writes:
Show 12 quoted lines
> One other point of discussion: I would like to change the name of this > feature. "Automerge" is a bit of an overloaded term and, IMO, doesn't > describe this feature very well. Several of the GUI diff programs have > a feature that they call "automerge" or "auto merge", and there's a flag > for Meld already in Git called "mergetool.meld.useAutoMerge" which could > cause confusion. > > Instead, I'd like to propose "mergetool.hideResolved" or the more > verbose "mergetool.hideResolvedConflicts" as the name. We're not really > merging anything (Git aleady did that before the mergetool is invoked), > but rather we're just not showing any conflicts that Git was already > able to resolve.
I have no objetion. I didn't think 'automerge' was bad, but it probably is too broad a word as you discuss in the above.
"hide resolved" sounds like the name that describes what it does quite well.
> #1: Use POSIX read and a while loop to emulate an awk-like approach:
I'd rather not to see us do "text processing" in shell, especially with "read -r". I just do not trust it (even with the "-r" option).
Having said that, I am not familiar enough to the Windows environment to know what is trustworthy and what is not (apparently, things like "sed" that I would intuitively place as much trust as anything else is giving us so much trouble out of box), so I'll shut up and listen to others.