Re: [PATCH v2 03/11] Prefer 'up-to-date' spelling
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Nov 7, 2019, 05:16 UTC
- Message-ID
- <xmqqh83gs1ui.fsf@gitster-ct.c.googlers.com>
- In-Reply-To
- <466aead9af6516ff94a5d217e58ab894e63088b7.1572973651.git.gitgitgadget@gmail.com>
"Elijah Newren via GitGitGadget" <gitgitgadget@gmail.com> writes:
Show 10 quoted lines
> diff --git a/unpack-trees.c b/unpack-trees.c > index 33ea7810d8..8ba2dc3267 100644 > --- a/unpack-trees.c > +++ b/unpack-trees.c > @@ -29,7 +29,7 @@ static const char *unpack_plumbing_errors[NB_UNPACK_TREES_ERROR_TYPES] > "Entry '%s' would be overwritten by merge. Cannot merge.", > > /* ERROR_NOT_UPTODATE_FILE */ > - "Entry '%s' not uptodate. Cannot merge.", > + "Entry '%s' not up-to-date. Cannot merge.",
As the name of this table says, this is a table of the plumbing errors that are given without translation, in order to allow scripts to read and act on them. Wouldn't touching it break the promise to the scripts?