Re: [PATCH v5 00/10] Turn git add-i into built-in
"Slavica Đukić via GitGitGadget" <gitgitgadget@gmail.com> writes:
Show 18 quoted lines
> This is the first version of a patch series to start porting
> git-add--interactive from Perl to C. Daniel Ferreira's patch series used as
> a head start:
> https://public-inbox.org/git/1494907234-28903-1-git-send-email-bnmvco@gmail.com/t/#u
>
> Changes since v4:
>
> * rename print_modified to list_modifed
> * the big change was implementing list_and_choose, which resulted in code
> refactoring, i.e. separating list_modified and status_cmd and making
> status_cmd use both list_modified and list_and_choose
> * implement struct choice instead of struct stuff_item as main data
> structure for list_and_choose
> * introduce list_only option and implement support for !list_only users
> * introduce highlighting of unique prefixes
>
> Note that authorship handling is slightly changed. In some of the commits, I
> used Original-patch-by instead of listing Daniel Ferreira as author.