Re: [PATCH 2/3] git-cvsserver: protect against NULL in crypt(3)
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Sep 16, 2021, 22:11 UTC
- Message-ID
- <xmqqczp8rx1c.fsf@gitster.g>
- In-Reply-To
- <20210915080948.11891-3-carenas@gmail.com>
Carlo Marcelo Arenas Belón <carenas@gmail.com> writes:
Show 6 quoted lines
> - if (crypt(descramble($password), $1) eq $1) {
> - $auth_ok = 1;
> + my $hash = crypt(descramble($password), $1);
> + if (defined $hash) {
> + $auth_ok = 1 if $hash eq $1;
> }It is not wrong per-se to separate the two checks into two separate parts of the conditional, but because we check for definedness only because comparison of it with $1 makes sense only when it is defined, writing it either like this,
if (defined $hash and $hash eq $1) {
$auth_ok = 1;
}or even like this,
$auth_ok = (defined $hash and $hash eq $1);
may be easier to read, no?