Re: [PATCH v8 35/41] apply: make 'be_silent' incompatible with 'apply_verbosely'
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jul 26, 2016, 19:37 UTC
- Message-ID
- <xmqqa8h41989.fsf@gitster.mtv.corp.google.com>
- In-Reply-To
- <20160627182429.31550-36-chriscool@tuxfamily.org>
Christian Couder <christian.couder@gmail.com> writes:
> It should be an error to have both be_silent and apply_verbosely set, > so let's check that in check_apply_state().
Doesn't that suggest that we do not want to have a new be_silent field at all? Perhaps we used to have apply_verbosely = <yes,no> resulting in only two verbosity levels, "verbose" and "normal", and you want to have another new one "total silence" or something?
If so perhaps it would be more appropriate to rename apply_verbosely to apply_verbosity that is no longer a boolean?