git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [ANNOUNCE] Git v2.27.0-rc2

From
Junio C Hamano <gitster@pobox.com>
Date
May 27, 2020, 16:47 UTC
Message-ID
<xmqqa71tmika.fsf@gitster.c.googlers.com>
In-Reply-To
<e66ea483-5e7f-4ebd-5ba8-91227efa454a@gmail.com>
Kaartic Sivaraam <kaartic.sivaraam@gmail.com> writes:
Show 14 quoted lines
> Hi Junio,
>
> On 27-05-2020 00:17, Junio C Hamano wrote:
>> Shourya Shukla (4):
>>        submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'
>>        gitfaq: files in .gitignore are tracked
>>        gitfaq: fetching and pulling a repository
>>        submodule: port subcommand 'set-url' from shell to C
>
> This is the only place where the `set-url` conversion from Shell to C
> is mentioned. I wonder if it's enough or if it needs a little bit more
> attention may be in the "Performance, Internal Implementation,
> Development Support etc." as it is a conversion of a submodule
> sub-command?

I'm not sure if it is worth the bits. It may matter _only_ if/when new implementaiton of set-url hurts the end-users by being buggy ;-)

Previous: Kaartic SivaraamNext: Kaartic Sivaraam
Message 3 of 6 in “[ANNOUNCE] Git v2.27.0-rc2”
  1. Junio C HamanoMay 26, 2020
  2. Kaartic SivaraamMay 26, 2020
  3. Junio C HamanoMay 27, 2020
  4. Kaartic SivaraamMay 28, 2020
  5. Pratyush YadavMay 27, 2020
  6. Junio C HamanoMay 27, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.