Re: [PATCH v2 06/11] bisect: libify `exit_if_skipped_commits` to `error_if_skipped*` and its dependents
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jan 31, 2020, 18:22 UTC
- Message-ID
- <xmqq5zgrbi5e.fsf@gitster-ct.c.googlers.com>
- In-Reply-To
- <20200128144026.53128-7-mirucam@gmail.com>
Miriam Rubio <mirucam@gmail.com> writes:
> From: Pranit Bauva <pranit.bauva@gmail.com> > > Since we want to get rid of git-bisect.sh it would be necessary to
Please add back the missing comma after ".sh" for readability.
Show 8 quoted lines
> convert those exit() calls to return statements so that errors can be > reported. > > Emulate try catch in C by converting `exit(<positive-value>)` to > `return <negative-value>`. Follow POSIX conventions to return > <negative-value> to indicate error. > > Handle this return in dependent function `bisect_next_all()`.
It makes it sound as if there were multiple callers and this change converted only one of them---"Update all callers to handle the error returns" would avoid such a misunderstanding.
Show 29 quoted lines
> diff --git a/bisect.c b/bisect.c
> index 83cb5b3a98..a7a5d158e6 100644
> --- a/bisect.c
> +++ b/bisect.c
> @@ -661,11 +661,11 @@ static void bisect_common(struct rev_info *revs)
> mark_edges_uninteresting(revs, NULL, 0);
> }
>
> -static void exit_if_skipped_commits(struct commit_list *tried,
> +static int error_if_skipped_commits(struct commit_list *tried,
> const struct object_id *bad)
> {
> if (!tried)
> - return;
> + return 0;
>
> printf("There are only 'skip'ped commits left to test.\n"
> "The first %s commit could be any of:\n", term_bad);
> @@ -676,7 +676,13 @@ static void exit_if_skipped_commits(struct commit_list *tried,
> if (bad)
> printf("%s\n", oid_to_hex(bad));
> printf(_("We cannot bisect more!\n"));
> - exit(2);
> +
> + /*
> + * We don't want to clean the bisection state
> + * as we need to get back to where we started
> + * by using `git bisect reset`.
> + */What this comment says may be true, but does it belong here? After returning, the caller will exit(2) without cleaning anyway with or without this patch, so I am a bit puzzled about the comment.
Show 36 quoted lines
> + return -2;
> }
>
> static int is_expected_rev(const struct object_id *oid)
> @@ -949,7 +955,7 @@ int bisect_next_all(struct repository *r, const char *prefix, int no_checkout)
> {
> struct rev_info revs;
> struct commit_list *tried;
> - int reaches = 0, all = 0, nr, steps;
> + int reaches = 0, all = 0, nr, steps, res;
> struct object_id *bisect_rev;
> char *steps_msg;
>
> @@ -972,8 +978,9 @@ int bisect_next_all(struct repository *r, const char *prefix, int no_checkout)
> * We should exit here only if the "bad"
> * commit is also a "skip" commit.
> */
> - exit_if_skipped_commits(tried, NULL);
> -
> + res = error_if_skipped_commits(tried, NULL);
> + if (res < 0)
> + exit(-res);
> printf(_("%s was both %s and %s\n"),
> oid_to_hex(current_bad_oid),
> term_good,
> @@ -990,7 +997,9 @@ int bisect_next_all(struct repository *r, const char *prefix, int no_checkout)
> bisect_rev = &revs.commits->item->object.oid;
>
> if (oideq(bisect_rev, current_bad_oid)) {
> - exit_if_skipped_commits(tried, current_bad_oid);
> + res = error_if_skipped_commits(tried, current_bad_oid);
> + if (res)
> + exit(-res);
> printf("%s is the first %s commit\n", oid_to_hex(bisect_rev),
> term_bad);
> show_diff_tree(r, prefix, revs.commits->item);