Re: [RFC PATCH v2] test-lib: drop comment about test_description
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Feb 25, 2023, 22:50 UTC
- Message-ID
- <xmqq5ybpuzq7.fsf@gitster.g>
- In-Reply-To
- <20230225190526.21780-1-rybak.a.v@gmail.com>
Andrei Rybak <rybak.a.v@gmail.com> writes:
> ... The assignment > of "test_description" and the process of writing tests in general are > described in detail in "t/README". So drop the obsolete comment.
Sounds sensible.
> An alternative solution is to move the comment down to the usage of > variable "test_description".
Or at the beginning, as the comment is about "how you can use this test-lib.sh test library in your tests".
I have no strong preference. Just dropping it sounds easier, as a more readable description already exists elsewhere.
Show 20 quoted lines
> t/test-lib.sh | 6 ------ > 1 file changed, 6 deletions(-) > > diff --git a/t/test-lib.sh b/t/test-lib.sh > index d272cca008..62136caee5 100644 > --- a/t/test-lib.sh > +++ b/t/test-lib.sh > @@ -645,12 +645,6 @@ u200c=$(printf '\342\200\214') > > export _x05 _x35 LF u200c EMPTY_TREE EMPTY_BLOB ZERO_OID OID_REGEX > > -# Each test should start with something like this, after copyright notices: > -# > -# test_description='Description of this test... > -# This test checks if command xyzzy does the right thing... > -# ' > -# . ./test-lib.sh > test "x$TERM" != "xdumb" && ( > test -t 1 && > tput bold >/dev/null 2>&1 &&