Re: [PATCH] builtin/revert.c: refactor using an enum for cmd-action
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jan 11, 2024, 19:37 UTC
- Message-ID
- <xmqq5xzzhda6.fsf@gitster.g>
- In-Reply-To
- <1ed0e249-dab9-4cf3-9b76-c8797b97c9c5@gmail.com>
Phillip Wood <phillip.wood123@gmail.com> writes:
> I think ACTION_NONE was intended to covey that the user did not pass > one of the OPT_CMDMODE() options like "--continue" as there isn't a > "--start" option. I don't have a strong opinion between "_NONE" and > "_START".
I agree with you why NONE is called as such. If "revert" does not take "--start" (I do not remember offhand), I would think it would be better to follow suit.