Re: [PATCH v10 3/9] strbuf: add a case insensitive starts_with()
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Mar 8, 2018, 23:12 UTC
- Message-ID
- <xmqq4llq88ms.fsf@gitster-ct.c.googlers.com>
- In-Reply-To
- <CACsJy8DWMmC9mvz783XQFHUopbVMH00LoqpW-CQunzg0qgiEEA@mail.gmail.com>
Duy Nguyen <pclouds@gmail.com> writes:
Show 6 quoted lines
>> extern int starts_with(const char *str, const char *prefix); >> +extern int startscase_with(const char *str, const char *prefix); > > This name is a bit hard to read. Boost [1] goes with istarts_with. I > wonder if it's better. If not I guess either starts_with_case or > starts_case_with will improve readability.
starts_with_case() sounds quite strange even though starts_with_icase() may make it clear that it is "a variant of starts_with() function that ignores case". I dunno. dir.c::cmp_icase() takes the _icase suffix for not quite the way that is consistent with that understanding, though.