[ANNOUNCE] Git v2.16.3
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Mar 22, 2018, 22:11 UTC
- Message-ID
- <xmqq4ll7lq0r.fsf@gitster-ct.c.googlers.com>
The latest maintenance release Git v2.16.3 is now available at the usual places. It merges many small fixes and documentation updates that have been in the 'master' branch for a few weeks.
The tarballs are found at:
https://www.kernel.org/pub/software/scm/git/
The following public repositories all have a copy of the 'v2.16.3' tag and the 'maint' branch that the tag points at:
url = https://kernel.googlesource.com/pub/scm/git/git url = git://repo.or.cz/alt-git.git url = https://github.com/gitster/git
----------------------------------------------------------------
Git v2.16.3 Release Notes =========================
Fixes since v2.16.2 -------------------
* "git status" after moving a path in the working tree (hence making it appear "removed") and then adding with the -N option (hence making that appear "added") detected it as a rename, but did not report the old and new pathnames correctly.
* "git commit --fixup" did not allow "-m<message>" option to be used at the same time; allow it to annotate resulting commit with more text.
* When resetting the working tree files recursively, the working tree of submodules are now also reset to match.
* Fix for a commented-out code to adjust it to a rather old API change around object ID.
* When there are too many changed paths, "git diff" showed a warning message but in the middle of a line.
* The http tracing code, often used to debug connection issues, learned to redact potentially sensitive information from its output so that it can be more safely sharable.
* Crash fix for a corner case where an error codepath tried to unlock what it did not acquire lock on.
* The split-index mode had a few corner case bugs fixed.
* Assorted fixes to "git daemon".
* Completion of "git merge -s<strategy>" (in contrib/) did not work well in non-C locale.
* Workaround for segfault with more recent versions of SVN.
* Recently introduced leaks in fsck have been plugged.
* Travis CI integration now builds the executable in 'script' phase
to follow the established practice, rather than during
'before_script' phase. This allows the CI categorize the failures
better ('failed' is project's fault, 'errored' is build
environment's).Also contains various documentation updates and code clean-ups.
----------------------------------------------------------------
Changes since v2.16.2 are as follows:
Ben Peart (1):
fsmonitor: update documentation to remove reference to invalid config settingsBrandon Williams (1):
oidmap: ensure map is initializedChristian Ludwig (1):
t9001: use existing helper in send-email testEric Sunshine (2):
git-worktree.txt: fix missing ")" typo
git-worktree.txt: fix indentation of example and text of 'add' commandEric Wong (2):
fsck: fix leak when traversing trees
git-svn: control destruction order to avoid segfaultGenki Sky (1):
test-lib.sh: unset XDG_CACHE_HOMEJeff King (10):
t5570: use ls-remote instead of clone for interp tests
t/lib-git-daemon: record daemon log
daemon: fix off-by-one in logging extended attributes
daemon: handle NULs in extended attribute string
t/lib-git-daemon: add network-protocol helpers
daemon: fix length computation in newline stripping
t0205: drop redundant test
git-sh-i18n: check GETTEXT_POISON before USE_GETTEXT_SCHEME
commit: drop uses of get_cached_commit_buffer()
revision: drop --show-all optionJonathan Tan (2):
http: support cookie redaction when tracing
http: support omitting data from tracesJuan F. Codagnone (1):
mailinfo: avoid segfault when can't open filesJunio C Hamano (2):
worktree: say that "add" takes an arbitrary commit in short-help
Git 2.16.3Kaartic Sivaraam (2):
Doc/gitsubmodules: make some changes to improve readability and syntax
Doc/git-submodule: improve readability and grammar of a sentenceMathias Rav (1):
files_initial_transaction_commit(): only unlock if lockedMotoki Seki (1):
Documentation/gitsubmodules.txt: avoid non-ASCII apostrophesNguyễn Thái Ngọc Duy (12):
t2203: test status output with porcelain v2 format
Use DIFF_DETECT_RENAME for detect_rename assignments
wt-status.c: coding style fix
wt-status.c: catch unhandled diff status codes
wt-status.c: rename rename-related fields in wt_status_change_data
wt-status.c: handle worktree renames
read-cache.c: change type of "temp" in write_shared_index()
read-cache.c: move tempfile creation/cleanup out of write_shared_index
diff.c: flush stdout before printing rename warnings
read-cache: don't write index twice if we can't write shared index
completion: fix completing merge strategies on non-C locales
gitignore.txt: elaborate shell glob syntaxRamsay Jones (2):
config.mak.uname: remove SPARSE_FLAGS setting for cygwin
Makefile: suppress a sparse warning for pack-revindex.cRandall S. Becker (1):
hashmap.h: remove unused variableRené Scharfe (2):
describe: use strbuf_add_unique_abbrev() for adding short hashes
cocci: simplify check for trivial format stringsRobert P. J. Day (2):
t/: correct obvious typo "detahced"
Correct mispellings of ".gitmodule" to ".gitmodules"SZEDER Gábor (11):
travis-ci: build Git during the 'script' phase
t5541: add 'test_i18ngrep's missing filename parameter
t5812: add 'test_i18ngrep's missing filename parameter
t6022: don't run 'git merge' upstream of a pipe
t4001: don't run 'git status' upstream of a pipe
t5510: consolidate 'grep' and 'test_i18ngrep' patterns
t5536: let 'test_i18ngrep' read the file without redirection
t: move 'test_i18ncmp' and 'test_i18ngrep' to 'test-lib-functions.sh'
t: validate 'test_i18ngrep's parameters
t: make 'test_i18ngrep' more informative on failure
t: document 'test_must_fail ok=<signal-name>'Stefan Beller (5):
t/lib-submodule-update.sh: clarify test
t/lib-submodule-update.sh: fix test ignoring ignored files in submodules
unpack-trees: oneway_merge to update submodules
submodule: submodule_move_head omits old argument in forced case
Documentation/git-status: clarify status table for porcelain modeStefan Moch (2):
t7001: add test case for --dry-run
mv: remove unneeded 'if (!show_only)'Thomas Gummerer (3):
read-cache: fix reading the shared index for other repos
split-index: don't write cache tree with null oid entries
travis: run tests with GIT_TEST_SPLIT_INDEXTodd Zullinger (1):
doc: mention 'git show' defaults to HEADYasushi SHOJI (1):
bisect: debug: convert struct object to object_idbrian m. carlson (1):
docs/interpret-trailers: fix agreement errorÆvar Arnfjörð Bjarmason (2):
commit doc: document that -c, -C, -F and --fixup with -m error
commit: add support for --fixup <commit> -m"<extra message>"