git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 1/5] treewide: rename 'struct exclude' to 'struct path_pattern'

From
Junio C Hamano <gitster@pobox.com>
Date
Sep 5, 2019, 21:03 UTC
Message-ID
<xmqq4l1qpiaw.fsf@gitster-ct.c.googlers.com>
In-Reply-To
<20190905065518.GD21450@sigill.intra.peff.net>
Jeff King <peff@peff.net> writes:
Show 12 quoted lines
> I wonder if there's a name that could more clearly distinguish the two.
> Or if it's sufficient to just become Git jargon that "pathspec" is the
> command-line one and "path_pattern" is the file-based one (we're at
> least pretty consistent about the former already).
>
> I think one could also make an argument that the name collision is a
> sign that these two things should actually share both syntax and
> implementation, since we're exposing too similar-but-not-quite versions
> of the same idea to users. But given the compatibility issues, it's
> probably not worth changing the user facing parts at this point (and I
> also haven't thought too hard about it; there may be reasons why the two
> _should_ differ).
Hmph.  I did not realize there are so many differences X-<.  

A pathspec is relative to $CWD, and there is a syntax, i.e. prefixing with ":(top)", to make it relative to the root level. An entry in a .gitignore file will never affect paths outside the directory the file appears in. And there should never be such a mechanism to allow it.

An entry without slash in .gitignore is a basename match, and there is a syntax i.e. prefixing with "/", to anchor it to a single directory. A pathspec without slash also can be a basename match (e.g. "*.c" matches "a/b.c" as well as "d.c"). A pathspec with a slash can be made to tail-match (e.g. "**/*.c" matches "a/b.c", "a/b/c.c", etc.) but I do not think of a way to make an entry with a slash in a .gitignore file a tail-match the same way. I do not think this is intended but merely a missing feature.

So, yes, eventually we may want to make them more similar, but I suspect that there are some things that should be in one but never be in the other.

Previous: Jeff KingNext: Derrick Stolee via GitGitGadget
Message 4 of 11 in “Refactor excludes library”
  1. 0/5 Refactor excludes libraryDerrick Stolee via GitGitGadget, Sep 3, 2019
  2. 1/5 treewide: rename 'struct exclude' to 'struct path_pattern'Derrick Stolee via GitGitGadget, Sep 3, 2019
  3. Jeff KingSep 5, 2019
  4. Junio C HamanoSep 5, 2019
  5. 2/5 treewide: rename 'struct exclude_list' to 'struct pattern_list'Derrick Stolee via GitGitGadget, Sep 3, 2019
  6. 3/5 treewide: rename 'EXCL_FLAG_' to 'PATTERN_FLAG_'Derrick Stolee via GitGitGadget, Sep 3, 2019
  7. 5/5 unpack-trees: rename 'is_excluded_from_list()'Derrick Stolee via GitGitGadget, Sep 3, 2019
  8. Elijah NewrenSep 4, 2019
  9. 4/5 treewide: rename 'exclude' methods to 'pattern'Derrick Stolee via GitGitGadget, Sep 3, 2019
  10. Elijah NewrenSep 4, 2019
  11. Junio C HamanoSep 6, 2019

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.