git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 01/10] bisect--helper: introduce new `write_in_file()` function

From
Junio C Hamano <gitster@pobox.com>
Date
Feb 26, 2020, 19:06 UTC
Message-ID
<xmqq4kvdjhhc.fsf@gitster-ct.c.googlers.com>
In-Reply-To
<20200226101429.81327-2-mirucam@gmail.com>
Miriam Rubio <mirucam@gmail.com> writes:
Show 5 quoted lines
> Let's refactor code adding a new `write_in_file()` function
> that opens a file for writing a message and closes it.
>
> This removes some duplicated code and makes the code simpler,
> clearer and easier to understand.

I find it a bit too much self promotion ;-) With what we see only in this step, the code is not so much simpler nor easier to understand. Perhaps when we see more callers in the remainder of the series, we may start to appreciate it, but if that is the case, we should clarify it here, e.g.

    This helper will be used in later steps and makes the code
    simpler, ...
Show 10 quoted lines
> +static int write_in_file(const char *filepath, const char *content, int append)
> +{
> +	FILE *fp = NULL;
> +	const char *mode = append ? "a" : "w";
> +
> +	fp = fopen(filepath, mode);
> +	if (!fp)
> +		return error_errno(_("could not open the file '%s'"), filepath);
> +	if (!fprintf(fp, "%s\n", content))
> +		return error_errno(_("could not write in file '%s'"), filepath);

Use and non-use of definite article being inconstent between "open the file X" vs "write in file X" bothers me as a reader here.

Wouldn't it be more common to say "write TO" here, not "write IN"?
> +	return fclose(fp);

We didn't use to say error_errno(_("could not close ...")) in the original, so we stay silent and return an error (EOF, which is a negative integer) from here.

Show 25 quoted lines
> +}
> +
>  static int check_term_format(const char *term, const char *orig_term)
>  {
>  	int res;
> @@ -104,7 +117,7 @@ static int check_term_format(const char *term, const char *orig_term)
>  
>  static int write_terms(const char *bad, const char *good)
>  {
> -	FILE *fp = NULL;
> +	char *content = xstrfmt("%s\n%s", bad, good);
>  	int res;
>  
>  	if (!strcmp(bad, good))
> @@ -113,12 +126,9 @@ static int write_terms(const char *bad, const char *good)
>  	if (check_term_format(bad, "bad") || check_term_format(good, "good"))
>  		return -1;
>  
> -	fp = fopen(git_path_bisect_terms(), "w");
> -	if (!fp)
> -		return error_errno(_("could not open the file BISECT_TERMS"));
> +	res = write_in_file(git_path_bisect_terms(), content, 0);
> +	free(content);
>  
> -	res = fprintf(fp, "%s\n%s\n", bad, good);

With just this one callsite, I do not think it is a good idea to lose the "write a formatted output without an extra allcoation" by introducing this wrapper. The equation may become different if we see more (a lot more) callsites that already have strings ready to be written that can use this helper, though.

> -	res |= fclose(fp);
>  	return (res < 0) ? -1 : 0;

The return value is a bit strange here, but it is inherited from the original, so I'll let it pass.

>  }
Previous: Miriam RubioNext: Miriam Rubio
Message 3 of 20 in “Finish converting git bisect to C part 2”
  1. Miriam RubioFeb 26, 2020
  2. 01/10 bisect--helper: introduce new `write_in_file()` functionMiriam Rubio, Feb 26, 2020
  3. Junio C HamanoFeb 26, 2020
  4. 03/10 bisect--helper: finish porting `bisect_start()` to CMiriam Rubio, Feb 26, 2020
  5. 02/10 bisect--helper: reimplement `bisect_next` and `bisect_auto_next` shell functions in CMiriam Rubio, Feb 26, 2020
  6. Junio C HamanoFeb 26, 2020
  7. Miriam R.Feb 27, 2020
  8. Junio C HamanoFeb 27, 2020
  9. Miriam R.Mar 6, 2020
  10. Junio C HamanoMar 6, 2020
  11. Christian CouderMar 11, 2020
  12. 04/10 bisect--helper: retire `--bisect-clean-state` subcommandMiriam Rubio, Feb 26, 2020
  13. 05/10 bisect--helper: retire `--next-all` subcommandMiriam Rubio, Feb 26, 2020
  14. 06/10 bisect--helper: reimplement `bisect_autostart` shell function in CMiriam Rubio, Feb 26, 2020
  15. Johannes SchindelinFeb 27, 2020
  16. 07/10 bisect--helper: reimplement `bisect_state` & `bisect_head` shell functions in CMiriam Rubio, Feb 26, 2020
  17. Johannes SchindelinFeb 27, 2020
  18. 08/10 bisect--helper: retire `--check-expected-revs` subcommandMiriam Rubio, Feb 26, 2020
  19. 09/10 bisect--helper: retire `--write-terms` subcommandMiriam Rubio, Feb 26, 2020
  20. 10/10 bisect--helper: retire `--bisect-autostart` subcommandMiriam Rubio, Feb 26, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.