git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 1/1] doc(stash): clarify the description of `save`

From
Junio C Hamano <gitster@pobox.com>
Date
Oct 11, 2019, 05:29 UTC
Message-ID
<xmqq36fzj1d4.fsf@gitster-ct.c.googlers.com>
In-Reply-To
<20191010102828.GA12497@cat>
Thomas Gummerer <t.gummerer@gmail.com> writes:
Show 15 quoted lines
> On 10/10, Johannes Schindelin via GitGitGadget wrote:
>> From: Johannes Schindelin <johannes.schindelin@gmx.de>
>> 
>> The original phrasing of this paragraph made at least one person stumble
>> over the word "from" (thinking that it was a typo and "from" was
>> intended), and other readers chimed in, agreeing that it was confusing:
>> https://public-inbox.org/git/0102016b8d597569-c1f6cfdc-cb45-4428-8737-cb1bc30655d8-000000@eu-west-1.amazonses.com/#t
>> 
>> Let's rewrite that paragraph for clarity.
>> 
>> Inspired-by-a-patch-by: Catalin Criste <cris_linu_w@yahoo.com>
>> Signed-off-by: Johannes Schindelin <johannes.schindelin@gmx.de>
>
> Thanks for picking this thread up again, I had already forgotten about
> it.  The updated wording sounds like an improvement to me.

To me too. I would have just done s/form/become/ out of laziness and aiming for conciseness, but the new and separate sentence is good, too.

Thanks, both.
Show 23 quoted lines
>
>> ---
>>  Documentation/git-stash.txt | 5 +++--
>>  1 file changed, 3 insertions(+), 2 deletions(-)
>> 
>> diff --git a/Documentation/git-stash.txt b/Documentation/git-stash.txt
>> index 8fbe12c66c..53e1a1205d 100644
>> --- a/Documentation/git-stash.txt
>> +++ b/Documentation/git-stash.txt
>> @@ -87,8 +87,9 @@ The `--patch` option implies `--keep-index`.  You can use
>>  save [-p|--patch] [-k|--[no-]keep-index] [-u|--include-untracked] [-a|--all] [-q|--quiet] [<message>]::
>>  
>>  	This option is deprecated in favour of 'git stash push'.  It
>> -	differs from "stash push" in that it cannot take pathspecs,
>> -	and any non-option arguments form the message.
>> +	differs from "stash push" in that it cannot take pathspecs.
>> +	Instead, all non-option arguments are concatenated to form the stash
>> +	message.
>>  
>>  list [<options>]::
>>  
>> -- 
>> gitgitgadget
Previous: Thomas Gummerer
Message 4 of 4 in “Make the description of git stash save clearer”
  1. 0/1 Make the description of git stash save clearerJohannes Schindelin via GitGitGadget, Oct 10, 2019
  2. 1/1 doc(stash): clarify the description of `save`Johannes Schindelin via GitGitGadget, Oct 10, 2019
  3. Thomas GummererOct 10, 2019
  4. Junio C HamanoOct 11, 2019

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.