Re: [PATCH] config: restructure format_config() for better control flow
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Aug 20, 2015, 20:19 UTC
- Message-ID
- <xmqq1tex7lwd.fsf@gitster.dls.corp.google.com>
- In-Reply-To
- <20150820144504.GA22935@sigill.intra.peff.net>
Jeff King <peff@peff.net> writes:
Show 15 quoted lines
> On Thu, Aug 20, 2015 at 04:14:22PM +0200, SZEDER Gábor wrote: > >> Commit 578625fa91 (config: add '--name-only' option to list only >> variable names, 2015-08-10) modified format_config() such that it >> returned from the middle of the function when showing only keys, >> resulting in ugly code structure. >> >> Reorganize the if statements and dealing with the key-value delimiter to >> make the function easier to read. > > This looks good to me. What do you think of these on top? > > [1/3]: format_config: don't init strbuf > [2/3]: format_config: simplify buffer handling > [3/3]: get_urlmatch: avoid useless strbuf write
All four including the thread-starter by SZEDER look good to me. Thanks.