git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2] receive-pack.c: consolidate find header logic

From
Junio C Hamano <gitster@pobox.com>
Date
Dec 30, 2021, 23:01 UTC
Message-ID
<xmqq1r1tofyf.fsf@gitster.g>
In-Reply-To
<pull.1125.v2.git.git.1640758765723.gitgitgadget@gmail.com>
"John Cai via GitGitGadget" <gitgitgadget@gmail.com> writes:
Show 10 quoted lines
> From: John Cai <johncai86@gmail.com>
>
> There are two functions that have very similar logic of finding a header
> value. find_commit_header, and find_header. We can conslidate the logic
> by using find_commit_header and replacing the logic in find_header.
>
> Introduce a new function find_header_max, which is equivalent to
> find_commit_header except it takes a len parameter that determines how
> many bytes to read. find_commit_header can then call find_header_max
> with 0 as the len.

find_header_max() is not the name of the function that finds the largest header? That is misleading.

<git-compat-util.h> defines a few helper functions that take a counted string, and they are named with _mem() suffix after the name of their NUL-terminated counterparts (if exists). skip_prefix() has skip_prefix_mem(), strip_suffix() has strip_suffix_mem().

find_header_mem() or something along that line, perhaps?
Show 12 quoted lines
> diff --git a/commit.c b/commit.c
> index a348f085b2b..2ed115e04a0 100644
> --- a/commit.c
> +++ b/commit.c
> @@ -1631,12 +1631,14 @@ struct commit_list **commit_list_append(struct commit *commit,
>  	return &new_commit->next;
>  }
>  
> -const char *find_commit_header(const char *msg, const char *key, size_t *out_len)
> +const char *find_header_max(const char *msg, const char *key,
> +			size_t len,
> +			size_t *out_len)

If <len> is meant to be the length part of <ptr,len> pair, we should have it immediately after the <ptr> parameter.

	find_header_mem(const char *msg, size_t len,
        		const char *key, size_t *out_len)
That makes it clear to the readers that <msg, len> are close friends.
Also, I have a feeling that ...
Show 6 quoted lines
>  {
>  	int key_len = strlen(key);
>  	const char *line = msg;
>  
> -	while (line) {
> +	while (line && (len == 0 || line < msg + len)) {

... we do not want this special casing of "if !len". By making the caller responsible to _always_ supply the length of msg, we can lose the conditional.

Show 10 quoted lines
>  		const char *eol = strchrnul(line, '\n');
>  
>  		if (line == eol)
> @@ -1653,6 +1655,10 @@ const char *find_commit_header(const char *msg, const char *key, size_t *out_len
>  	return NULL;
>  }
>  
> +const char *find_commit_header(const char *msg, const char *key, size_t *out_len)
> +{
> +	return find_header_max(msg, key, 0, out_len);
I.e. find_header_mem(msg, strlen(msg), key, out_len);
Show 27 quoted lines
> diff --git a/builtin/receive-pack.c b/builtin/receive-pack.c
> index 9f4a0b816cf..b69ead8dcda 100644
> --- a/builtin/receive-pack.c
> +++ b/builtin/receive-pack.c
> @@ -581,32 +581,19 @@ static char *prepare_push_cert_nonce(const char *path, timestamp_t stamp)
>  	return strbuf_detach(&buf, NULL);
>  }
>  
> -/*
> - * NEEDSWORK: reuse find_commit_header() from jk/commit-author-parsing
> - * after dropping "_commit" from its name and possibly moving it out
> - * of commit.c
> - */
>  static char *find_header(const char *msg, size_t len, const char *key,
>  			 const char **next_line)
>  {
> +	size_t out_len;
> +	const char *val = find_header_max(msg, key, len, &out_len);
> +
> +	if (val == NULL)
> +		return NULL;
> +
> +	if (next_line)
> +		*next_line = val + out_len + 1;
> +
> +	return xmemdupz(val, out_len);
>  }

Yup, something along that line. Note that find_header() does make it clear that the <msg, len> parameters form a pair. We want to do the same for the new helper.

Previous: John Cai via GitGitGadgetNext: John Cai via GitGitGadget
Message 6 of 16 in “Consolidate find_header logic into one function”
  1. 0/2 Consolidate find_header logic into one functionJohn Cai via GitGitGadget, Dec 27, 2021
  2. 1/2 receive-pack.c: consolidate find header logicJohn Cai via GitGitGadget, Dec 27, 2021
  3. Junio C HamanoDec 27, 2021
  4. 2/2 commit.c: rename find_commit_header to find_headerJohn Cai via GitGitGadget, Dec 27, 2021
  5. receive-pack.c: consolidate find header logicJohn Cai via GitGitGadget, Dec 29, 2021
  6. Junio C HamanoDec 30, 2021
  7. receive-pack.c: consolidate find header logicJohn Cai via GitGitGadget, Dec 31, 2021
  8. Junio C HamanoJan 4, 2022
  9. John CaiJan 4, 2022
  10. receive-pack.c: consolidate find header logicJohn Cai via GitGitGadget, Jan 5, 2022
  11. Junio C HamanoJan 5, 2022
  12. receive-pack.c: consolidate find header logicJohn Cai via GitGitGadget, Jan 6, 2022
  13. Junio C HamanoJan 6, 2022
  14. receive-pack.c: consolidate find header logicJohn Cai via GitGitGadget, Jan 6, 2022
  15. John CaiJan 8, 2022
  16. Junio C HamanoJan 8, 2022

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.