Re: [PATCH 3/3] Tests file for git-remote-mediawiki
- From
Matthieu Moy <matthieu.moy@grenoble-inp.fr>
- Date
- Jun 8, 2012, 08:57 UTC
- Message-ID
- <vpqboku18qk.fsf@bauges.imag.fr>
- In-Reply-To
- <4FD1B209.702@ensimag.imag.fr>
"Simon.Cathebras" <Simon.Cathebras@ensimag.imag.fr> writes:
Show 9 quoted lines
> On 06/06/2012 22:18, Matthieu Moy wrote: >> Simon Cathebras<simon.cathebras@ensimag.imag.fr> writes: >> >>> From: Charles Roussel<charles.roussel@ensimag.fr> >>> >>> Those scripts test the functions of git-remote-mediawiki. >>> t9360: test cases for git clone. Including tests of cloning just a category, just a precise set of page and a classical use of clone on the whole wiki. >> Avoid long lines in code and commit messages (80 columns max) > Understood, it will be corrected in the next patch.
Detail: in emails, people generally leave blank lines to separate paragraphs, and in particular to separate one's own text from citation. Compare my response
http://thread.gmane.org/gmane.comp.version-control.git/199238/focus=199349
to yours to see what I mean
http://thread.gmane.org/gmane.comp.version-control.git/199238/focus=199468
> Do you mean that we should split the third patch into two patches ? > For instance:: > Patch 3/4: tests for git pull > Patch 4/4: tests for git push
Yes, except the title should mention git-remote-mediawiki, of course.
Show 8 quoted lines
>>> +test_expect_success 'git clone only create Main_Page.mw with a wiki with no other pages ' ' >>> + wiki_reset&& >>> + wiki_editpage foo "this page must be delete before the clone" false&& >> s/delete/deleted/ >>> + git_diff_directories mw_dir ref_page&& >> functions in tests are usually prefixed with test_ instead. > Fair enough. We have changed the function's name. Should we add such > prefix on functions like wiki_reset or wiki_delete page ?
I don't think so. They're not very specific to testing indeed, and really are specific to the wiki OTOH.
-- Matthieu Moy http://www-verimag.imag.fr/~moy/