[PATCH v3 1/3] test-lib-functions.sh: rename test_must_fail_acceptable()
- From
Ævar Arnfjörð Bjarmason <avarab@gmail.com>
- Date
- Aug 4, 2021, 23:05 UTC
- Message-ID
- <patch-v3-1.3-f45590a76d5-20210804T230335Z-avarab@gmail.com>
- In-Reply-To
- <cover-v3-0.3-00000000000-20210804T230335Z-avarab@gmail.com>
The test_must_fail_acceptable() is really a generic function that can check if something is a real "git command", e.g. "git", "test-tool" etc. Let's rename it in preparation for using it in another test function.
Signed-off-by: Ævar Arnfjörð Bjarmason <avarab@gmail.com> --- t/test-lib-functions.sh | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/t/test-lib-functions.sh b/t/test-lib-functions.sh index e28411bb75a..37da7d9a99a 100644 --- a/t/test-lib-functions.sh +++ b/t/test-lib-functions.sh @@ -895,7 +895,7 @@ list_contains () { # accepted by test_must_fail(). If the command is run with env, the env # and its corresponding variable settings will be stripped before we # test the command being run. -test_must_fail_acceptable () { +is_git_command_name () { if test "$1" = "env" then shift @@ -943,7 +943,7 @@ test_must_fail_acceptable () { # (Don't use 'success', use 'test_might_fail' instead.) # # Do not use this to run anything but "git" and other specific testable -# commands (see test_must_fail_acceptable()). We are not in the +# commands (see is_git_command_name()). We are not in the # business of vetting system supplied commands -- in other words, this # is wrong: # @@ -963,7 +963,7 @@ test_must_fail () { _test_ok= ;; esac - if ! test_must_fail_acceptable "$@" + if ! is_git_command_name "$@" then echo >&7 "test_must_fail: only 'git' is allowed: $*" return 1
-- 2.33.0.rc0.597.gc569a812f0a