Re: [PATCH] bisect: don't use invalid oid as rev when starting
- From
Johannes Schindelin <johannes.schindelin@gmx.de>
- Date
- Sep 23, 2020, 20:37 UTC
- Message-ID
- <nycvar.QRO.7.76.6.2009232229000.5061@tvgsbejvaqbjf.bet>
- In-Reply-To
- <20200923170915.21748-1-chriscool@tuxfamily.org>
Hi Christian,
On Wed, 23 Sep 2020, Christian Couder wrote:
Show 31 quoted lines
> In 06f5608c14 (bisect--helper: `bisect_start` shell function
> partially in C, 2019-01-02), we changed the following shell
> code:
>
> - rev=$(git rev-parse -q --verify "$arg^{commit}") || {
> - test $has_double_dash -eq 1 &&
> - die "$(eval_gettext "'\$arg' does not appear to be a valid revision")"
> - break
> - }
> - revs="$revs $rev"
>
> into:
>
> + char *commit_id = xstrfmt("%s^{commit}", arg);
> + if (get_oid(commit_id, &oid) && has_double_dash)
> + die(_("'%s' does not appear to be a valid "
> + "revision"), arg);
> +
> + string_list_append(&revs, oid_to_hex(&oid));
> + free(commit_id);
>
> In case of an invalid "arg" when "has_double_dash" is false, the old
> code would "break" out of the argument loop.
>
> In the new C code though, `oid_to_hex(&oid)` is unconditonally
> appended to "revs". This is wrong first because "oid" is junk as
> `get_oid(commit_id, &oid)` failed and second because it doesn't break
> out of the argument loop.
>
> Not breaking out of the argument loop means that "arg" is then not
> treated as a path restriction (which is wrong).Good catch!
Show 7 quoted lines
> This is a bug fix for the bug Miriam talks about in: > > https://lore.kernel.org/git/20200923072740.20772-1-mirucam@gmail.com/ > > and: > > https://lore.kernel.org/git/CAN7CjDDVp_i7dhpbAq5zrGW69nE6+SfivJQ-dembmu+WyqKiQQ@mail.gmail.com/
Thank you for clarifying.
Show 23 quoted lines
> diff --git a/builtin/bisect--helper.c b/builtin/bisect--helper.c
> index 7dcc1b5188..538fa6f16b 100644
> --- a/builtin/bisect--helper.c
> +++ b/builtin/bisect--helper.c
> @@ -486,12 +486,16 @@ static int bisect_start(struct bisect_terms *terms, const char **argv, int argc)
> return error(_("unrecognized option: '%s'"), arg);
> } else {
> char *commit_id = xstrfmt("%s^{commit}", arg);
> - if (get_oid(commit_id, &oid) && has_double_dash)
> - die(_("'%s' does not appear to be a valid "
> - "revision"), arg);
> -
> - string_list_append(&revs, oid_to_hex(&oid));
> + int res = get_oid(commit_id, &oid);
> free(commit_id);
> + if (res) {
> + if (has_double_dash)
> + die(_("'%s' does not appear to be a valid "
> + "revision"), arg);
> + break;
> + } else {
> + string_list_append(&revs, oid_to_hex(&oid));
> + }I would find that a lot easier to read if it was reordered thusly:
if (!get_oidf(&oid, "%s^{commit}", arg))
string_list_append(&revs, oid_to_hex(&oid));
else if (!has_double_dash)
break;
else
die(_("'%s' does not appear to be a valid "
revision"), arg);And it would actually probably make sense to replace the `get_oid()` by `get_oid_committish()` in the first place.
Show 12 quoted lines
> } > } > pathspec_pos = i; > diff --git a/t/t6030-bisect-porcelain.sh b/t/t6030-bisect-porcelain.sh > index b886529e59..cb645cf8c8 100755 > --- a/t/t6030-bisect-porcelain.sh > +++ b/t/t6030-bisect-porcelain.sh > @@ -82,6 +82,13 @@ test_expect_success 'bisect fails if given any junk instead of revs' ' > git bisect bad $HASH4 > ' > > +test_expect_success 'bisect start without -- uses unknown stuff as path restriction' '
s/stuff/arg/ maybe?
The rest of the patch looks good to me.
Thank you, Dscho
Show 13 quoted lines
> + git bisect reset && > + git bisect start foo bar && > + grep foo ".git/BISECT_NAMES" && > + grep bar ".git/BISECT_NAMES" > +' > + > test_expect_success 'bisect reset: back in the master branch' ' > git bisect reset && > echo "* master" > branch.expect && > -- > 2.28.0.587.g1c7fdf1d8b > >