git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v3 1/1] rebase.c: make sure the active branch isn't moved when autostashing

From
Johannes Schindelin <johannes.schindelin@gmx.de>
Date
Aug 22, 2019, 12:27 UTC
Message-ID
<nycvar.QRO.7.76.6.1908221418540.46@tvgsbejvaqbjf.bet>
In-Reply-To
<20190821182941.12674-2-ben@wijen.net>
Hi Ben,
On Wed, 21 Aug 2019, Ben Wijen wrote:
Show 21 quoted lines
> Consider the following scenario:
>     git checkout not-the-master
>     work work work
>     git rebase --autostash upstream master
>
> Here 'rebase --autostash <upstream> <branch>' incorrectly moves the
> active branch (not-the-master) to master (before the rebase).
>
> The expected behavior: (58794775:/git-rebase.sh:526)
>     AUTOSTASH=$(git stash create autostash)
>     git reset --hard
>     git checkout master
>     git rebase upstream
>     git stash apply $AUTOSTASH
>
> The actual behavior: (6defce2b:/builtin/rebase.c:1062)
>     AUTOSTASH=$(git stash create autostash)
>     git reset --hard master
>     git checkout master
>     git rebase upstream
>     git stash apply $AUTOSTASH

Interesting. So the only difference is that the original rebase called `git reset --hard` on the current HEAD, while the new behavior tries to reset to the branch to which the user wants to switch, right away.

I can see that this would lead to possible problems e.g. if a file had been added between master and the current branch.

Show 5 quoted lines
> This commit reinstates the 'legacy script' behavior as introduced with
> 58794775: rebase: implement --[no-]autostash and rebase.autostash
>
> As with this commit the reset must never change the active branch,
> the 'HEAD is now at ...' message has now been removed.
Actually, I am not so sure that I like this change.

Previously, users had a chance to figure out to which revision the worktree was reset, before switching the branch (because switching the branch we _do_, via `git checkout master`).

Show 11 quoted lines
> diff --git a/builtin/rebase.c b/builtin/rebase.c
> index 670096c065..a928f44941 100644
> --- a/builtin/rebase.c
> +++ b/builtin/rebase.c
> @@ -1968,9 +1968,6 @@ int cmd_rebase(int argc, const char **argv, const char *prefix)
>  				state_dir_path("autostash", &options);
>  			struct child_process stash = CHILD_PROCESS_INIT;
>  			struct object_id oid;
> -			struct commit *head =
> -				lookup_commit_reference(the_repository,
> -							&options.orig_head);

This should probably be changed to look up `HEAD` instead, then, so that we can keep the message.

I.e. you probably want to use `get_oid("HEAD", &head_oid)` instead.
Show 72 quoted lines
>  			argv_array_pushl(&stash.args,
>  					 "stash", "create", "autostash", NULL);
> @@ -1991,17 +1988,14 @@ int cmd_rebase(int argc, const char **argv, const char *prefix)
>  				    options.state_dir);
>  			write_file(autostash, "%s", oid_to_hex(&oid));
>  			printf(_("Created autostash: %s\n"), buf.buf);
> -			if (reset_head(&head->object.oid, "reset --hard",
> +
> +			/*
> +			 * We might not be on orig_head yet:
> +			 * Make sure to reset w/o switching branches...
> +			 */
> +			if (reset_head(NULL, "reset --hard",
>  				       NULL, RESET_HEAD_HARD, NULL, NULL) < 0)
>  				die(_("could not reset --hard"));
> -			printf(_("HEAD is now at %s"),
> -			       find_unique_abbrev(&head->object.oid,
> -						  DEFAULT_ABBREV));
> -			strbuf_reset(&buf);
> -			pp_commit_easy(CMIT_FMT_ONELINE, head, &buf);
> -			if (buf.len > 0)
> -				printf(" %s", buf.buf);
> -			putchar('\n');
>
>  			if (discard_index(the_repository->index) < 0 ||
>  				repo_read_index(the_repository) < 0)
> diff --git a/t/t3420-rebase-autostash.sh b/t/t3420-rebase-autostash.sh
> index b8f4d03467..d1352096f2 100755
> --- a/t/t3420-rebase-autostash.sh
> +++ b/t/t3420-rebase-autostash.sh
> @@ -37,7 +37,6 @@ test_expect_success setup '
>  create_expected_success_am () {
>  	cat >expected <<-EOF
>  	$(grep "^Created autostash: [0-9a-f][0-9a-f]*\$" actual)
> -	HEAD is now at $(git rev-parse --short feature-branch) third commit
>  	First, rewinding head to replay your work on top of it...
>  	Applying: second commit
>  	Applying: third commit
> @@ -48,7 +47,6 @@ create_expected_success_am () {
>  create_expected_success_interactive () {
>  	q_to_cr >expected <<-EOF
>  	$(grep "^Created autostash: [0-9a-f][0-9a-f]*\$" actual)
> -	HEAD is now at $(git rev-parse --short feature-branch) third commit
>  	Applied autostash.
>  	Successfully rebased and updated refs/heads/rebased-feature-branch.
>  	EOF
> @@ -57,7 +55,6 @@ create_expected_success_interactive () {
>  create_expected_failure_am () {
>  	cat >expected <<-EOF
>  	$(grep "^Created autostash: [0-9a-f][0-9a-f]*\$" actual)
> -	HEAD is now at $(git rev-parse --short feature-branch) third commit
>  	First, rewinding head to replay your work on top of it...
>  	Applying: second commit
>  	Applying: third commit
> @@ -70,7 +67,6 @@ create_expected_failure_am () {
>  create_expected_failure_interactive () {
>  	cat >expected <<-EOF
>  	$(grep "^Created autostash: [0-9a-f][0-9a-f]*\$" actual)
> -	HEAD is now at $(git rev-parse --short feature-branch) third commit
>  	Applying autostash resulted in conflicts.
>  	Your changes are safe in the stash.
>  	You can run "git stash pop" or "git stash drop" at any time.
> @@ -306,4 +302,16 @@ test_expect_success 'branch is left alone when possible' '
>  	test unchanged-branch = "$(git rev-parse --abbrev-ref HEAD)"
>  '
>
> +test_expect_success 'never change active branch' '
> +	git checkout -b upstream unrelated-onto-branch &&
> +	test_when_finished "
> +		git reset --hard &&
> +		git checkout - &&
> +		git branch -D upstream" &&

I feel like we want to have a more meaningful branch name than "upstream", and then we can get away with leaving it in place, i.e. just

	test_when_finished "git reset --hard && git checkout -" &&
> +	echo changed >file0 &&
> +	git add file0 &&

Since `file0` is already tracked, I think that this `git add` invocation only distracts from the essence of this test case.

> +	git rebase --autostash upstream feature-branch &&
> +	test_cmp_rev upstream unrelated-onto-branch
Otherwise: well done! And thank you so much for fixing this.

Ciao, Dscho

Show 7 quoted lines
> +'
> +
>  test_done
> --
> 2.22.0
>
>
Previous: Ben WijenNext: Junio C Hamano
Message 11 of 38 in “git rebase: Make sure upstream branch is left alone.”
  1. 0/2 git rebase: Make sure upstream branch is left alone.Ben Wijen, Aug 18, 2019
  2. 2/2 rebase.c: make sure current branch isn't moved when autostashingBen Wijen, Aug 18, 2019
  3. Phillip WoodAug 20, 2019
  4. BenAug 20, 2019
  5. 0/1 git rebase: Make sure upstream branch is left alone.Ben Wijen, Aug 20, 2019
  6. 1/1 rebase.c: make sure current branch isn't moved when autostashingBen Wijen, Aug 20, 2019
  7. Eric SunshineAug 20, 2019
  8. Junio C HamanoAug 20, 2019
  9. 0/1 rebase.c: make sure the active branch isn't moved when autostashingBen Wijen, Aug 21, 2019
  10. 1/1 rebase.c: make sure the active branch isn't moved when autostashingBen Wijen, Aug 21, 2019
  11. Johannes SchindelinAug 22, 2019
  12. Junio C HamanoAug 22, 2019
  13. 1/1 rebase.c: make sure the active branch isn't moved when autostashingBen Wijen, Aug 26, 2019
  14. 1/1 rebase.c: make sure the active branch isn't moved when autostashingBen Wijen, Aug 26, 2019
  15. SZEDER GáborAug 26, 2019
  16. Johannes SchindelinAug 28, 2019
  17. Junio C HamanoAug 28, 2019
  18. Junio C HamanoAug 28, 2019
  19. 0/2 rebase.c: make sure current branch isn't moved when autostashingBen Wijen, Aug 29, 2019
  20. 1/2 builtin/rebase.c: make sure the active branch isn't moved when autostashingBen Wijen, Aug 29, 2019
  21. 2/2 builtin/rebase.c: Remove pointless messageBen Wijen, Aug 29, 2019
  22. 0/2 rebase.c: make sure current branch isn't moved when autostashingBen Wijen, Aug 30, 2019
  23. 1/2 builtin/rebase.c: make sure the active branch isn't moved when autostashingBen Wijen, Aug 30, 2019
  24. Junio C HamanoAug 30, 2019
  25. BenAug 31, 2019
  26. Junio C HamanoSep 1, 2019
  27. BenSep 1, 2019
  28. Junio C HamanoSep 2, 2019
  29. 2/2 builtin/rebase.c: Remove pointless messageBen Wijen, Aug 30, 2019
  30. 2/2 builtin/rebase.c: Remove pointless messageBen Wijen, Aug 30, 2019
  31. Junio C HamanoAug 30, 2019
  32. BenAug 31, 2019
  33. 1/2 t3420: never change upstream branchBen Wijen, Aug 18, 2019
  34. Junio C HamanoAug 19, 2019
  35. Phillip WoodAug 20, 2019
  36. Phillip WoodAug 19, 2019
  37. BenAug 19, 2019
  38. Junio C HamanoAug 19, 2019

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.