git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: Do test-path_is_{file,dir,exists} make sense anymore with -x?

From
Johannes Schindelin <johannes.schindelin@gmx.de>
Date
Feb 26, 2019, 19:58 UTC
Message-ID
<nycvar.QRO.7.76.6.1902262055260.41@tvgsbejvaqbjf.bet>
In-Reply-To
<20190226173542.GC19606@sigill.intra.peff.net>
Hi,
On Tue, 26 Feb 2019, Jeff King wrote:
> I had a vague notion that there was some reason (portability?) that we
> preferred to have the wrappers. But as your patch shows, they really are
> just calling "test" and nothing else.

Let's also not forget about the fact that `test -f` is actually not all that intuitive an interface. Whereas even somebody without training in software development (let alone Unix shell scripting) understands the meaning of

	test_path_is_file this-file.txt

And even for a trained eye, the trace of `test -f` is sometimes hard to read, as you do *not* see the exit code in the trace, so you have to guess from circumstantial evidence whether it failed or succeeded.

Ciao, Dscho

Previous: Jeff KingNext: Jeff King
Message 16 of 42 in “tests: replace test -(d|f) with test_path_is_(dir|file)”
  1. 0/1 [GSoC][PATCH] tests: replace test -(d|f) with test_path_is_(dir|file)Rohit Ashiwal via GitGitGadget, Feb 26, 2019
  2. 1/1 tests: replace `test -(d|f)` with test_path_is_(dir|file)Rohit Ashiwal via GitGitGadget, Feb 26, 2019
  3. Duy NguyenFeb 26, 2019
  4. Do test-path_is_{file,dir,exists} make sense anymore with -x?Ævar Arnfjörð Bjarmason, Feb 26, 2019
  5. SZEDER GáborFeb 26, 2019
  6. Jeff KingFeb 26, 2019
  7. SZEDER GáborFeb 26, 2019
  8. Jeff KingFeb 26, 2019
  9. SZEDER GáborMar 3, 2019
  10. Jeff KingMar 5, 2019
  11. SZEDER GáborMar 4, 2019
  12. Jeff KingMar 5, 2019
  13. Matthieu MoyFeb 26, 2019
  14. Jeff KingFeb 26, 2019
  15. Jeff KingFeb 26, 2019
  16. Johannes SchindelinFeb 26, 2019
  17. Jeff KingFeb 26, 2019
  18. Duy NguyenFeb 27, 2019
  19. Junio C HamanoMar 1, 2019
  20. Johannes SchindelinFeb 26, 2019
  21. Martin ÅgrenFeb 26, 2019
  22. Rohit AshiwalFeb 26, 2019
  23. Johannes SchindelinFeb 26, 2019
  24. Rohit AshiwalFeb 26, 2019
  25. Martin ÅgrenFeb 27, 2019
  26. 0/1 [GSoC][PATCH] t3600: use test_path_is_dir and test_path_is_fileRohit Ashiwal via GitGitGadget, Feb 26, 2019
  27. 1/1 t3600: use test_path_is_dir and test_path_is_fileRohit Ashiwal via GitGitGadget, Feb 26, 2019
  28. SZEDER GáborFeb 26, 2019
  29. Rohit AshiwalFeb 26, 2019
  30. Johannes SchindelinFeb 26, 2019
  31. Rohit AshiwalFeb 26, 2019
  32. 0/1 [GSoC][PATCH] t3600: use test_path_is_* helper functionsRohit Ashiwal via GitGitGadget, Feb 26, 2019
  33. 1/1 t3600: use test_path_is_* functionsRohit Ashiwal via GitGitGadget, Feb 26, 2019
  34. Duy NguyenFeb 27, 2019
  35. 0/1 [GSoC][PATCH] t3600: use test_path_is_* helper functionsRohit Ashiwal via GitGitGadget, Feb 28, 2019
  36. 1/1 t3600: use test_path_is_* functionsRohit Ashiwal via GitGitGadget, Feb 28, 2019
  37. [GSoC] acknowledging mistakesRohit Ashiwal, Feb 28, 2019
  38. Junio C HamanoMar 1, 2019
  39. Feeling confused a little bitRohit Ashiwal, Mar 1, 2019
  40. Rafael AscensãoMar 2, 2019
  41. Thomas GummererMar 2, 2019
  42. [GSoC] ThankingRohit Ashiwal, Mar 2, 2019

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.