git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: suggestion for git rebase -i

From
Seth Falcon <sfalcon@fhcrc.org>
Date
Jul 28, 2007, 15:52 UTC
Message-ID
<m2vec4seyf.fsf@ziti.fhcrc.org>
In-Reply-To
<Pine.LNX.4.64.0707280941380.14781@racer.site>
Johannes Schindelin <Johannes.Schindelin@gmx.de> writes:
> Why?  This is an implementation detail, and should not concern the
> user.

In the context of an existing editing session, the name of the tempfile is visible and relevant to the user (not just an implementation detail). For example, the tempfile name is useful when multi-tasking and one needs to get back to the buffer. As another reply pointed out, the name could also be used for editor mode customization.

So. When editing a commit message, the buffer is named COMMIT_EDITMSG. When editing a rebase -i buffer it is named todo. Is this a real problem? Of course not. But I think a slightly more descriptive name makes sense -- especially if other commands gain interactive modes and a user might have a number of them going at once (in different repos, e.g.).

+ seth
Previous: Jeff KingNext: Johannes Schindelin
Message 5 of 7 in “suggestion for git rebase -i”
  1. Seth FalconJul 28, 2007
  2. Johannes SchindelinJul 28, 2007
  3. Jeff KingJul 28, 2007
  4. Jeff KingJul 28, 2007
  5. Seth FalconJul 28, 2007
  6. Johannes SchindelinJul 28, 2007
  7. Seth FalconJul 28, 2007

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.