Re: [PATCH 1/5] bundle: add bundle verification options type
- From
Justin Tobler <jltobler@gmail.com>
- Date
- Nov 26, 2024, 15:59 UTC
- Message-ID
- <hg6gq4izm3jmmrmh5g6fy7ojxbgxc35y33gvm2blntfmto2hd2@ecd546locmbg>
- In-Reply-To
- <Z0WQC7mFvT4pKn0n@pks.im>
On 24/11/26 10:08AM, Patrick Steinhardt wrote:
Show 14 quoted lines
> On Thu, Nov 21, 2024 at 02:41:15PM -0600, Justin Tobler wrote:
> > diff --git a/bundle.h b/bundle.h
> > index 5ccc9a061a..bddf44c267 100644
> > --- a/bundle.h
> > +++ b/bundle.h
> > @@ -39,6 +39,10 @@ enum verify_bundle_flags {
> > int verify_bundle(struct repository *r, struct bundle_header *header,
> > enum verify_bundle_flags flags);
>
> Curious. I would have expected that `verify_bundle()` should receive the
> full `verify_bundle_opts` because these are so similarly named. Like
> this we have the weird situation where `unbundle()` seemingly receives
> the options that are intended for `verify_bundle()`, but we never pass
> them through in the first place.The `verify_bundle_opts` type should probably be renamed to `unbundle_opts`. As you mentioned, these options are not used directly by `verify_bundle()` as the current naming would suggest which is confusing. Really the intent is allow further configuration of `unbundle()`. This is evident in the next patch where the options are extended to further configure the git-index-pack(1) spawned through `unbundle()`. I'll update the naming in the next version.
-Justin