Re: [PATCH v7 3/6] fast-import: add feature command
- From
Sverre Rabbelier <srabbelier@gmail.com>
- Date
- Sep 12, 2009, 19:43 UTC
- Message-ID
- <fabb9a1e0909121243l240dcb68jbd0207bd4b21d4ca@mail.gmail.com>
- In-Reply-To
- <20090912185122.GQ1033@spearce.org>
Heya,
On Sat, Sep 12, 2009 at 20:51, Shawn O. Pearce <spearce@spearce.org> wrote:
> Where is the documentation for 'feature date-format=<FORMAT>'?
D'oh, I forgot, my bad.
> Also, IIRC the fast-import list agreed that the <feature> name must > match the re ^[a-zA-Z][a-zA-Z-]*$.
Ah, yes, of course, I'll update that.
> Saying that here does somewhat > help another fast-import developer to use the same stream format, > but it does not help a user to understand what features they can > ask for in their stream.
No, you're absolutely right, there should be a section on supported features.
> So its legal to change the data format in the middle of a stream?
I'll add a !seen_non_option_command check to parse_feature, perhaps renaming it to 'seen_data_command'?
-- Cheers, Sverre Rabbelier