[PATCH] fetch: use skip_prefix() instead of starts_with()
- From
René Scharfe <l.s.r@web.de>
- Date
- Nov 26, 2019, 11:18 UTC
- Message-ID
- <f6ed729b-3cd3-a91a-d69d-4960e4a0524f@web.de>
Get rid of magic numbers by letting skip_prefix() set the pointer "what".
Signed-off-by: René Scharfe <l.s.r@web.de> --- builtin/fetch.c | 12 +++--------- 1 file changed, 3 insertions(+), 9 deletions(-)
diff --git a/builtin/fetch.c b/builtin/fetch.c index 863c858fde..02e8619618 100644 --- a/builtin/fetch.c +++ b/builtin/fetch.c @@ -954,18 +954,12 @@ static int store_updated_refs(const char *raw_url, const char *remote_name, kind = ""; what = ""; } - else if (starts_with(rm->name, "refs/heads/")) { + else if (skip_prefix(rm->name, "refs/heads/", &what)) kind = "branch"; - what = rm->name + 11; - } - else if (starts_with(rm->name, "refs/tags/")) { + else if (skip_prefix(rm->name, "refs/tags/", &what)) kind = "tag"; - what = rm->name + 10; - } - else if (starts_with(rm->name, "refs/remotes/")) { + else if (skip_prefix(rm->name, "refs/remotes/", &what)) kind = "remote-tracking branch"; - what = rm->name + 13; - } else { kind = ""; what = rm->name; -- 2.24.0