Re: [PATCH] git-compat-util.h: Fix build without threads
- From
Bagas Sanjaya <bagasdotme@gmail.com>
- Date
- Nov 29, 2022, 03:46 UTC
- Message-ID
- <f6a8210b-d224-161d-d8bf-c1de7bca5367@gmail.com>
- In-Reply-To
- <a1e9449c-80b4-782d-faed-f2ae45420015@gmail.com>
On 11/29/22 10:30, Bagas Sanjaya wrote:
Show 17 quoted lines
> On 11/26/22 06:47, Ævar Arnfjörð Bjarmason wrote: >> Per f43cce23add (git-compat-util: add fallbacks for unlocked stdio, >> 2015-04-16) wouldn't it make more sense to do something like: >> >> #ifdef NO_FLOCKFILE >> #undef _POSIX_THREAD_SAFE_FUNCTIONS >> #endif >> >> Or the other way around here? I.e. have _POSIX_THREAD_SAFE_FUNCTIONS >> define/undefine NO_FLOCKFILE? > > From the commit you mentioned, I think that above is OK. However, > because I'm no C expert, I'm unsure whether I should go with #undef > suggestion alone or #undef following by no-op declaration below #endif. > > Thanks. >
Also, I think NO_FLOCKFILE is rather misnomer: it is the knob when there is no _POSIX_THREAD_SAFE_FUNCTION, so the knob name should have been "NO_POSIX_THREAD_SAFE_FUNCTION" instead.
-- An old man doll... just what I always wanted! - Clara