git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH] send-email: clarify SMTP encryption settings

From
Bagas Sanjaya <bagasdotme@gmail.com>
Date
Apr 11, 2021, 05:48 UTC
Message-ID
<f347c0bf-b08e-34d7-e1ae-796a3e619b8c@gmail.com>
In-Reply-To
<xmqqlf9rklkb.fsf@gitster.g>
On 10/04/21 07.52, Junio C Hamano wrote:
Show 5 quoted lines
> Isn't SMTPS (running SMTP over SSL encrypted connection) the one
> that was once deprecated until it got resurrected)?
> 
> STARTTLS is not all that SMTP specific---POP and IMAP can also start
> in cleartext and upgrade with STARTTLS the same way, no?

Wikipedia entry on Opportunistic TLS [1] said that STARTTLS is not specific to SMTP, but also to various protocols:

> The STARTTLS command for IMAP and POP3 is defined in RFC 2595, for SMTP in RFC 3207, for XMPP in RFC 6120 and for NNTP in RFC 4642. For IRC, the IRCv3 Working Group has defined the STARTTLS extension. FTP uses the command "AUTH TLS" defined in RFC 4217 and LDAP defines a protocol extension OID in RFC 2830. HTTP uses upgrade header. 
[1]: https://en.wikipedia.org/wiki/Opportunistic_TLS
-- 
An old man doll... just what I always wanted! - Clara
Previous: Junio C HamanoNext: brian m. carlson
Message 8 of 11 in “send-email: clarify SMTP encryption settings”
  1. send-email: clarify SMTP encryption settingsDrew DeVault, Apr 9, 2021
  2. Eric SunshineApr 9, 2021
  3. Georgios KontaxisApr 9, 2021
  4. Drew DeVaultApr 9, 2021
  5. Junio C HamanoApr 10, 2021
  6. Drew DeVaultApr 10, 2021
  7. Junio C HamanoApr 10, 2021
  8. Bagas SanjayaApr 11, 2021
  9. brian m. carlsonApr 10, 2021
  10. Drew DeVaultApr 10, 2021
  11. Junio C HamanoApr 10, 2021

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.