Re: [PATCH v3 4/6] Export also the has_un{staged,committed}_changed() functions
- From
Jakub Narębski <jnareb@gmail.com>
- Date
- Oct 5, 2016, 19:20 UTC
- Message-ID
- <e5f0ae3b-c65a-4cd0-0726-23e7a2985b5e@gmail.com>
- In-Reply-To
- <017586232230ad87dd7cde5801e011cce9255bc0.1475586229.git.johannes.schindelin@gmx.de>
W dniu 04.10.2016 o 15:05, Johannes Schindelin pisze:
> Subject: Export also the has_un{staged,committed}_changed() functionss/changed/changes/ that is d -> s
Those are has_unstaged_changes() and has_uncommitted_changes().
Though I wonder if "other has_un*_changes() functions" would be more readable (while shorter), if less specific...
Show 5 quoted lines
> > They will be used in the upcoming rebase helper. > > Signed-off-by: Johannes Schindelin <johannes.schindelin@gmx.de> > ---
[...]
Show 5 quoted lines
> -/* The following function expect that the caller took care of reading the index. */ > +/* The following functions expect that the caller took care of reading the index. */ > +int has_unstaged_changes(void); > +int has_uncommitted_changes(void); > int require_clean_work_tree(const char *action, const char *hint, int gently);
Nice to see the fix in comment too. Good work!
-- Jakub Narębski