Re: [PATCH v3 0/3] sparse-index: expand/collapse based on 'index.sparse'
- From
Derrick Stolee <stolee@gmail.com>
- Date
- Oct 27, 2021, 20:08 UTC
- Message-ID
- <e1c6fe43-ebd1-7c6f-c5b6-c528fb4e6774@gmail.com>
- In-Reply-To
- <pull.1059.v3.git.1635358812.gitgitgadget@gmail.com>
On 10/27/2021 2:20 PM, Victoria Dye via GitGitGadget wrote:
Show 11 quoted lines
> Changes since V2 > ================ > > * Rename can_convert_to_sparse to is_sparse_index_allowed to more > accurately reflect what the function returns. > * Remove index-iterating checks from is_sparse_index_allowed, leaving only > inexpensive checks on config settings & sparse checkout patterns. Checks > are still part of convert_to_sparse to ensure it behaves exactly as it > did before this series. > * Restructure ensure_correct_sparsity for better readability. > * Fix test_env variable scope.
I took a full read through this version, taking special look at the changes since v2. I think this version is good to go!
Thanks, -Stolee