Re: git-clone works with ssh but not with http/https/git
- From
- Erez Zilber <erezzi.list@gmail.com>
- Date
- Jun 24, 2008, 14:16 UTC
- Message-ID
- <ce513bcc0806240716o2556a187wef877fc51ebe9606@mail.gmail.com>
- In-Reply-To
- <20080624135429.GA6905@atn.sw.ru>
On Tue, Jun 24, 2008 at 4:54 PM, Anton Gladkov <agladkov@parallels.com> wrote:
Show 13 quoted lines
> On Tue, Jun 24, 2008 at 05:42:14PM +0400, Erez Zilber wrote: >> I guess that the problem is that no proper mapping exists. That's why >> I see the following in /var/log/httpd/error_log: >> >> [Tue Jun 24 16:31:52 2008] [error] [client 172.16.0.7] File does not >> exist: /var/www/html/pub >> >> What do I need to add in /etc/httpd/conf.d/ in order to set the >> mapping to /pub/git instead of /var/www/html/pub ? Is there an example >> that shows how to map? > > IMO the simplest way is to create a symlink 'pub' in /var/www/html directory > pointing to /pub and to add 'Options FollowSymLinks' to <Directory /> in httpd.conf.
Adding the symlink solved the cloning with http problem.
Thanks, Erez