git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v3 0/4] Optimization batch 12: miscellaneous unthemed stuff

From
Derrick Stolee <stolee@gmail.com>
Date
Jun 4, 2021, 18:42 UTC
Message-ID
<c9d596f3-cfc9-4bb7-1008-4873dafd8270@gmail.com>
In-Reply-To
<YLpWbLkaqVYqTrGL@coredump.intra.peff.net>
On 6/4/2021 12:35 PM, Jeff King wrote:
Show 33 quoted lines
> On Fri, Jun 04, 2021 at 08:48:21AM -0700, Elijah Newren wrote:
> 
>>>>           Signed-off-by: Elijah Newren <newren@gmail.com>
>>>>      +    Acked-by: Derrick Stolee <dstolee@microsoft.com>
>>>
>>> I believe the sign-off should always be the last thing in
>>> the message. Perhaps Junio is willing to fix this without a
>>> re-roll?
>>
>> Interesting, this is the first I've ever heard of such a requirement,
>> and I've submitted patches this way numerous times and have seen
>> others do it.  A quick search through git.git history says there are
>> 5133 commits that place such trailers before the author's
>> Signed-off-by, and 1175 that place them after.  While the former is
>> clearly more common, and some of the latter could have been Junio
>> adding trailers while applying the patches, there still seem like
>> plenty of counter-examples suggesting that there is no rule here.
> 
> I don't think there's a hard rule here. The usual advice (which I also
> didn't find documented from a quick grep, but hopefully is kind of
> intuitive) is that trailers should be chronological.
> 
> So if you picked up a patch from person X who signed off, then you
> modified and signed off the result, then Junio signed off after
> applying, we'd expect that chain of custody to be represented by reading
> top to bottom. And that's what happens if you use "am -s", "commit -s",
> etc.
> 
> Whether "Acked-by" happens after the author signs off or not is
> debatable. Obviously it happens after the version of the patch that is
> sent out. But if you re-send with an Acked-by, is the signoff your one
> from before that happened first, or a new one that happened as you sent
> out the patch? Perhaps a question for the philosophers. ;)
I guess I was just interpreting that the "Acked-by" was part of
the content you created, and hence it should be covered by the
sign-off. I can imagine that if Junio added it, then it would be
after your sign-off but before his.
 
> Anyway, I think it is perfectly fine either way (as your numbers
> indicate).
I agree. I didn't mean to make a big deal of it.

Thanks, -Stolee

Previous: Jeff KingNext: Elijah Newren
Message 32 of 39 in “Optimization batch 12: miscellaneous unthemed stuff”
  1. 0/5 Optimization batch 12: miscellaneous unthemed stuffElijah Newren via GitGitGadget, May 27, 2021
  2. 1/5 merge-ort: replace string_list_df_name_compare with faster alternativeElijah Newren via GitGitGadget, May 27, 2021
  3. René ScharfeMay 27, 2021
  4. Elijah NewrenMay 27, 2021
  5. René ScharfeMay 28, 2021
  6. Elijah NewrenMay 28, 2021
  7. Taylor BlauMay 28, 2021
  8. Elijah NewrenMay 28, 2021
  9. 2/5 diffcore-rename: avoid unnecessary strdup'ing in break_idxElijah Newren via GitGitGadget, May 27, 2021
  10. 3/5 diffcore-rename: enable limiting rename detection to relevant destinationsElijah Newren via GitGitGadget, May 27, 2021
  11. 4/5 Fix various issues found in commentsElijah Newren via GitGitGadget, May 27, 2021
  12. 5/5 merge-ort: miscellaneous touch-upsElijah Newren via GitGitGadget, May 27, 2021
  13. 0/5 Optimization batch 12: miscellaneous unthemed stuffElijah Newren via GitGitGadget, Jun 1, 2021
  14. 1/5 merge-ort: replace string_list_df_name_compare with faster alternativeElijah Newren via GitGitGadget, Jun 1, 2021
  15. Derrick StoleeJun 2, 2021
  16. 3/5 diffcore-rename: enable limiting rename detection to relevant destinationsElijah Newren via GitGitGadget, Jun 1, 2021
  17. Derrick StoleeJun 3, 2021
  18. Elijah NewrenJun 3, 2021
  19. 2/5 diffcore-rename: avoid unnecessary strdup'ing in break_idxElijah Newren via GitGitGadget, Jun 1, 2021
  20. 4/5 Fix various issues found in commentsElijah Newren via GitGitGadget, Jun 1, 2021
  21. 5/5 merge-ort: miscellaneous touch-upsElijah Newren via GitGitGadget, Jun 1, 2021
  22. Derrick StoleeJun 3, 2021
  23. 0/4 Optimization batch 12: miscellaneous unthemed stuffElijah Newren via GitGitGadget, Jun 4, 2021
  24. 1/4 merge-ort: replace string_list_df_name_compare with faster alternativeElijah Newren via GitGitGadget, Jun 4, 2021
  25. 3/4 Fix various issues found in commentsElijah Newren via GitGitGadget, Jun 4, 2021
  26. 4/4 merge-ort: miscellaneous touch-upsElijah Newren via GitGitGadget, Jun 4, 2021
  27. 2/4 diffcore-rename: avoid unnecessary strdup'ing in break_idxElijah Newren via GitGitGadget, Jun 4, 2021
  28. Derrick StoleeJun 4, 2021
  29. Elijah NewrenJun 4, 2021
  30. Elijah NewrenJun 4, 2021
  31. Jeff KingJun 4, 2021
  32. Derrick StoleeJun 4, 2021
  33. Elijah NewrenJun 4, 2021
  34. Jeff KingJun 4, 2021
  35. 0/4 Optimization batch 12: miscellaneous unthemed stuffElijah Newren via GitGitGadget, Jun 8, 2021
  36. 2/4 diffcore-rename: avoid unnecessary strdup'ing in break_idxElijah Newren via GitGitGadget, Jun 8, 2021
  37. 1/4 merge-ort: replace string_list_df_name_compare with faster alternativeElijah Newren via GitGitGadget, Jun 8, 2021
  38. 3/4 Fix various issues found in commentsElijah Newren via GitGitGadget, Jun 8, 2021
  39. 4/4 merge-ort: miscellaneous touch-upsElijah Newren via GitGitGadget, Jun 8, 2021

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.