Re: [RFC PATCH v2 1/6] status: add noob format from status.noob config
- From
- Dragan Simic <dsimic@manjaro.org>
- Date
- Oct 30, 2023, 01:38 UTC
- Message-ID
- <c31418c38996d1e67a4f3602458a5a91@manjaro.org>
- In-Reply-To
- <xmqqjzr4gaie.fsf@gitster.g>
On 2023-10-30 02:32, Junio C Hamano wrote:
Show 28 quoted lines
> Jacob Stopak <jacob@initialcommit.io> writes: >> diff --git a/table.h b/table.h >> new file mode 100644 >> index 0000000000..c9e8c386de >> --- /dev/null >> +++ b/table.h >> @@ -0,0 +1,6 @@ >> +#ifndef TABLE_H >> +#define TABLE_H >> + >> +void print_noob_status(struct wt_status *s); >> + >> +#endif /* TABLE_H */ > > I am guessing that your plan is to add other "distim_noob_add()" and > other "noob" variant of operations for various Git subcommands here, > but I really do not think you want to add table.[ch] that has logic > for such random set of Git subcommands copied and tweaked from all > over the place, as the only trait being shared among them will > become "they are written by Jacob Stopak", that is not a very useful > grouping of the functions. It is not even "this file collects all > the code that produce tabular output from Git"---"git status -s" > already gives tabular output, for example, without using any of the > "I only want to draw a table with three columns of equal width" > logic. Adding code that are necessary to add yet another output > mode for "git status" directly to where various output modes of "git > status" are implemented, i.e. wt-status.c, and do similar changes for > each command would make more sense, I would think.
Furthermore, "extended" should perhaps be used instead of "noob" throughout, to reflect the planned naming of the configuration option values.