git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v3 3/4] reset: add option "--merge-safe" to "git reset"

From
Christian Couder <christian.couder@gmail.com>
Date
Sep 17, 2009, 12:12 UTC
Message-ID
<c07716ae0909170512k3c2ec7m21e69e9acfdfd81f@mail.gmail.com>
In-Reply-To
<4AB1E41F.6050304@viscovery.net>
On Thu, Sep 17, 2009 at 9:24 AM, Johannes Sixt <j.sixt@viscovery.net> wrote:
Show 25 quoted lines
> Junio C Hamano schrieb:
>> Johannes Sixt <j.sixt@viscovery.net> writes:
>>> Junio C Hamano schrieb:
>>> (2) The intended use-case of --merge-safe is to point the branch head to a
>>> different commit, but to carry the changes that currently are in the index
>>> and wd over to the new commit, similar to checkout --merge.
>
> This is actually an operation that I need quite often, but I can do it
> only by way of git stash.
>
> Clarification: I did not say that I actually meant to carry *only* the
> index and wd changes to the new commit. That is, the operation I have in
> mind can roughly be done in terms of
>
>  $ git stash
>  $ git reset --hard $target
>  $ git stash pop
>
>> I have _no_ idea what the intended use-case of --merge-safe is, and that
>> was why I asked Christian for clarification in the previous round.  The
>> answer was still not clear enough so I pointed out --merge-safe could be
>> still doing a wrong thing even in _his_ use-case.
>
> Reading Christian in 200909170554.49416.chriscool@tuxfamily.org, I think
> this *is* his use-case? Christian?

Yes, I agree, it can be used instead of git stash. By the way Linus, in his patch that added the --merge option, said that --merge could be used like that.

So for this use case --merge-safe is safer than --merge, and that's why I suggested that name. But I know I suck at naming things, so there is probably a better name.

Thanks, Christian.

Previous: Johannes SixtNext: Johannes Sixt
Message 9 of 15 in “"git reset --merge" related improvements”
  1. 0/4 "git reset --merge" related improvementsChristian Couder, Sep 17, 2009
  2. 1/4 reset: add a few tests for "git reset --merge"Christian Couder, Sep 17, 2009
  3. 2/4 reset: use "unpack_trees()" directly instead of "git read-tree"Christian Couder, Sep 17, 2009
  4. 3/4 reset: add option "--merge-safe" to "git reset"Christian Couder, Sep 17, 2009
  5. Junio C HamanoSep 17, 2009
  6. Johannes SixtSep 17, 2009
  7. Junio C HamanoSep 17, 2009
  8. Johannes SixtSep 17, 2009
  9. Christian CouderSep 17, 2009
  10. Johannes SixtSep 17, 2009
  11. Christian CouderSep 17, 2009
  12. Junio C HamanoSep 17, 2009
  13. Christian CouderSep 17, 2009
  14. Daniel BarkalowSep 17, 2009
  15. 4/4 reset: add test cases for "--merge-safe" optionChristian Couder, Sep 17, 2009

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.