Re: [PATCH 00/23] http*: refactor (v6)
- From
Tay Ray Chuan <rctay89@gmail.com>
- Date
- Jun 7, 2009, 00:41 UTC
- Message-ID
- <be6fef0d0906061741p6f3864a9m25d25e23ef0db760@mail.gmail.com>
- In-Reply-To
- <7v8wk5dyrw.fsf@alter.siamese.dyndns.org>
Hi,
On Sun, Jun 7, 2009 at 2:04 AM, Junio C Hamano<gitster@pobox.com> wrote:
Show 7 quoted lines
> Thanks, will queue, but please double check the result after I push it > out, as I found some other changes not listed above, relative to what was > queued in 'pu' (I am not complaining; I am asking your extra set of > eyeballs in case I somehow screwed up applying your series to my tree). > > - return value of fetch_indices() is 0 when http_get_info_packs() returns > HTTP_MISSING_TARGET (both in http-push.c and http-walker.c);
This is correct. I had noted this in the patch; perhaps I should have included it in the cover letter.
> - break the function definition of run_request_queue() by removing "void"
> from the parameter list ("send out fetch requests on queue" -- no need
> to resend, I fixed it up again while applying);My bad. I hadn't noticed that you've already been doing this.
> - update the error checking in transport.c:get_refs_via_curl() to make it > look more similar to what are in fetch_indices() in both http-push.c and > http-walker.c.
Yes. I noted this in the patch text.
> - add unused "cleanup:" label to get_refs_via_curl() in transport.c > (again no need to resend, I fixed it up while applying);
Indeed. It was an uncaught consequence of the previous change.
> - add back a few missing "->local = NULL" I screwed up while applying the > previous series.
I'll have to take a look at those.
Show 5 quoted lines
> By the way, this is not your fault at all, but for a patch series > description, "shortlog" is a sucky way, as we can see below. When you > talk about "patch #15", the reader cannot find which one you are talking > about but has to go back to the MUA, so the list is useless for that > purpose.
Is there a way to do this with git-format-patch? ("this" being a list of numbered patches, instead of them being grouped by author)
-- Cheers, Ray Chuan