Re: [PATCH 5/9] Add "skip_unmerged" option to unpack_trees.
- From
Johannes Schindelin <johannes.schindelin@gmx.de>
- Date
- Feb 5, 2008, 01:32 UTC
- Message-ID
- <alpine.LSU.1.00.0802050129570.8543@racer.site>
- In-Reply-To
- <alpine.LNX.1.00.0802041335530.13593@iabervon.org>
Hi,
On Mon, 4 Feb 2008, Daniel Barkalow wrote:
Show 9 quoted lines
> if (any_files) {
> - if (o->merge) {
> + if (skip_entry) {
> + do
> + o->pos++;
> + while (o->pos < active_nr &&
> + !strcmp(active_cache[o->pos]->name,
> + src[0]->name));
> + } else if (o->merge) {Maybe it is just me, but I would have thought
while (++o->pos < active_nr) if (strcmp(active_cache[o->pos]->name, src[0]->name)) break;
more readable. But that's maybe because I have trouble with do ... while constructs logically (I like to see the loop condition first, then the loop body).
Ciao, Dscho