git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 1/4] Split up default "core" config parsing into helper routine

From
Linus Torvalds <torvalds@linux-foundation.org>
Date
Jun 18, 2008, 22:58 UTC
Message-ID
<alpine.LFD.1.10.0806181552590.2907@woody.linux-foundation.org>
In-Reply-To
<20080618224919.GA22599@sigill.intra.peff.net>
On Wed, 18 Jun 2008, Jeff King wrote:
Show 6 quoted lines
> 
> Maybe it would be easier still to read (and unmeasurably more efficient)
> to actually do it like:
> 
>         if (!prefixcmp(var, "core."))
>                 return git_default_core_config(var+5, value);

I considered it, but I think that screws up error reporting (ie if some value is unparseable, it would then print out the wrong variable name).

It would also have made the patches much less obvious. So it's a "future enhancement" thing.

> I was curious a while ago and instrumented git_config to write the PID
> to a tempfile each time it was called. Most git programs parse the
> config files (.git/config, ~/.gitconfig, /etc/gitconfig) three times
> each, with some doing it as many as five times.

Yeah, I know. I love the config file format (quite frankly, anybody who thinks XML and friends are sane is a total moron and should be shot before they reproduce), but the whole parsing code was a really quick hack.

I've several times wanted to rewrite it so that it does something smarter (parse it once, save it in a nice data structure), but let's face it, the upside is rather small. So I've never really ended up having the energy.

> Then we could do useful things like say "you specified core.foobar, but
> there is no such variable."

No. We could already do that (just add it to the end of git_default_core_config - it should be called last even if there was a chain), but avoid doing that very much on purpose.

Why? Because it's really irritating to have a parser that complains about newer values (or old deprecated ones) that don't matter for that version of the program.

			Linus
Previous: Jeff KingNext: Jeff King
Message 7 of 16 in “Add 'core.fsyncobjectfiles' config option”
  1. 0/4 Add 'core.fsyncobjectfiles' config optionLinus Torvalds, Jun 18, 2008
  2. 1/4 Split up default "core" config parsing into helper routineLinus Torvalds, Jun 18, 2008
  3. 2/4 Split up default "user" config parsing into helper routineLinus Torvalds, Jun 18, 2008
  4. 3/4 Split up default "i18n" and "branch" config parsing into helper routinesLinus Torvalds, Jun 18, 2008
  5. 4/4 Add config option to enable 'fsync()' of object filesLinus Torvalds, Jun 18, 2008
  6. Jeff KingJun 18, 2008
  7. Linus TorvaldsJun 18, 2008
  8. Jeff KingJun 18, 2008
  9. Linus TorvaldsJun 18, 2008
  10. Jeff KingJun 19, 2008
  11. Linus TorvaldsJun 19, 2008
  12. Linus TorvaldsJun 19, 2008
  13. Daniel BarkalowJun 19, 2008
  14. Junio C HamanoJun 19, 2008
  15. Jeff KingJun 19, 2008
  16. Eric RaibleJun 19, 2008

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.