git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v4 1/2] merge-file: let conflict markers match end-of-line style of the context

From
Johannes Schindelin <johannes.schindelin@gmx.de>
Date
Jan 27, 2016, 07:58 UTC
Message-ID
<alpine.DEB.2.20.1601270856150.2964@virtualbox>
In-Reply-To
<xmqqsi1kavr2.fsf@gitster.mtv.corp.google.com>
Hi Junio,
On Tue, 26 Jan 2016, Junio C Hamano wrote:
Show 36 quoted lines
> Junio C Hamano <gitster@pobox.com> writes:
> 
> > Johannes Schindelin <johannes.schindelin@gmx.de> writes:
> >
> >> +static int is_cr_needed(xdfenv_t *xe1, xdfenv_t *xe2, xdmerge_t *m)
> >> +{
> >> +	int needs_cr;
> >> +
> >> +	/* Match post-images' preceding, or first, lines' end-of-line style */
> >> +	needs_cr = is_eol_crlf(&xe1->xdf2, m->i1 ? m->i1 - 1 : 0);
> >> +	if (needs_cr)
> >> +		needs_cr = is_eol_crlf(&xe2->xdf2, m->i2 ? m->i2 - 1 : 0);
> >> +	/* Look at pre-image's first line, unless we already settled on LF */
> >> +	if (needs_cr)
> >> +		needs_cr = is_eol_crlf(&xe1->xdf1, 0);
> >> +	/* If still undecided, use LF-only */
> >> +	return needs_cr < 0 ? 0 : needs_cr;
> >> +}
> >
> > Retrying with other images when needs_cr is either -1 (unknown) or 1
> > (known to be true) was tricky; I had to read it twice and think
> > about it for 30 seconds before convincing myself that the code does
> > what the log message specifies it should.
> >
> > That is probably because I was thinking in terms of "do we know that
> > we need to add a CR?"; if I read "needs_cr" in my head as "we might
> > want to add a CR", everything becomes much more clear, but perhaps
> > it is just me.
> >
> > The return value of this function is definitely "do we need and want
> > to add a CR", and it is appropriately named.
> >
> > Thanks.
> 
> Just in case it was unclear, none of the comment above means I want
> any part of the patch redone--I am happy with this patch as-is.

Thanks for saying that... I was about to try to make things clearer, but I could not think of a better term than "needs_cr". The existing code already has "add_nl" (which means: add a newline *iff* the block to be copied does not yet have a newline), which I also found confusing.

Oh wait, maybe "eol_is_crlf" instead of "needs_cr"?

Ciao, Dscho

Previous: Junio C HamanoNext: Junio C Hamano
Message 46 of 55 in “Let merge-file write out conflict markers with correct EOLs”
  1. 0/2 Let merge-file write out conflict markers with correct EOLsJohannes Schindelin, Jan 22, 2016
  2. 1/2 convert: add a helper to determine the correct EOL for a given pathJohannes Schindelin, Jan 22, 2016
  3. Junio C HamanoJan 22, 2016
  4. Johannes SchindelinJan 22, 2016
  5. Torsten BögershausenJan 23, 2016
  6. Johannes SchindelinJan 24, 2016
  7. Torsten BögershausenJan 23, 2016
  8. Johannes SchindelinJan 24, 2016
  9. 2/2 merge-file: consider core.crlf when writing merge markersJohannes Schindelin, Jan 22, 2016
  10. Junio C HamanoJan 22, 2016
  11. Johannes SchindelinJan 22, 2016
  12. Junio C HamanoJan 22, 2016
  13. Johannes SchindelinJan 24, 2016
  14. Eric SunshineJan 22, 2016
  15. Eric SunshineJan 22, 2016
  16. Johannes SchindelinJan 24, 2016
  17. Eric SunshineJan 24, 2016
  18. Johannes SchindelinJan 25, 2016
  19. Torsten BögershausenJan 23, 2016
  20. Johannes SchindelinJan 24, 2016
  21. Beat BolliJan 22, 2016
  22. 0/1 Let merge-file write out conflict markers with correct EOLsJohannes Schindelin, Jan 24, 2016
  23. 1/1 merge-file: let conflict markers match end-of-line style of the contextJohannes Schindelin, Jan 24, 2016
  24. Torsten BögershausenJan 24, 2016
  25. Torsten BögershausenJan 24, 2016
  26. Johannes SchindelinJan 25, 2016
  27. Ramsay JonesJan 25, 2016
  28. Johannes SchindelinJan 26, 2016
  29. Ramsay JonesJan 26, 2016
  30. Johannes SchindelinJan 26, 2016
  31. Junio C HamanoJan 24, 2016
  32. Johannes SchindelinJan 25, 2016
  33. 0/2 Let merge-file write out conflict markers with correct EOLsJohannes Schindelin, Jan 25, 2016
  34. 1/2 merge-file: let conflict markers match end-of-line style of the contextJohannes Schindelin, Jan 25, 2016
  35. Torsten BögershausenJan 25, 2016
  36. Johannes SchindelinJan 25, 2016
  37. Junio C HamanoJan 25, 2016
  38. Johannes SchindelinJan 26, 2016
  39. Junio C HamanoJan 26, 2016
  40. 2/2 merge-file: ensure that conflict sections match eol styleJohannes Schindelin, Jan 25, 2016
  41. Johannes SchindelinJan 25, 2016
  42. 0/2 Let merge-file write out conflict markers with correct EOLsJohannes Schindelin, Jan 26, 2016
  43. 1/2 merge-file: let conflict markers match end-of-line style of the contextJohannes Schindelin, Jan 26, 2016
  44. Junio C HamanoJan 26, 2016
  45. Junio C HamanoJan 26, 2016
  46. Johannes SchindelinJan 27, 2016
  47. Junio C HamanoJan 27, 2016
  48. Johannes SchindelinJan 27, 2016
  49. Junio C HamanoJan 27, 2016
  50. Johannes SchindelinJan 28, 2016
  51. 2/2 merge-file: ensure that conflict sections match eol styleJohannes Schindelin, Jan 26, 2016
  52. 0/2 Let merge-file write out conflict markers with correct EOLsJohannes Schindelin, Jan 27, 2016
  53. 1/2 merge-file: let conflict markers match end-of-line style of the contextJohannes Schindelin, Jan 27, 2016
  54. 2/2 merge-file: ensure that conflict sections match eol styleJohannes Schindelin, Jan 27, 2016
  55. Junio C HamanoJan 27, 2016

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.