Re: [PATCH] rerere: remove duplicated functions
- From
Johannes Schindelin <johannes.schindelin@gmx.de>
- Date
- Feb 14, 2009, 22:28 UTC
- Message-ID
- <alpine.DEB.1.00.0902142327520.10279@pacific.mpi-cbg.de>
- In-Reply-To
- <1234650064-639-1-git-send-email-szeder@ira.uka.de>
Hi,
On Sat, 14 Feb 2009, SZEDER Gábor wrote:
Show 8 quoted lines
> Both rerere.c and builtin-rerere.c define the static functions > rr_path() and has_resolution() the exact same way. To eliminate this > code duplication this patch turns the functions in rerere.c > non-static, and makes builtin-rerere.c use them. Also, since this > puts these two functions into the global namespace, rename them to > rerere_path() and has_rerere_resolution(), respectively, and rename > their "name" parameter to "hex", because it better reflects what that > parameter actually is.
Thanks. As I started that code in C, I dare say "ACK" here :-)
Ciao, Dscho