Re: [PATCH 11/15] Add strbuf_vaddf(), use it in strbuf_addf(), and add strbuf_initf()
- From
Johannes Schindelin <johannes.schindelin@gmx.de>
- Date
- Jun 29, 2008, 13:40 UTC
- Message-ID
- <alpine.DEB.1.00.0806291436520.9925@racer>
- In-Reply-To
- <7vskuwek9w.fsf@gitster.siamese.dyndns.org>
Hi,
On Sun, 29 Jun 2008, Junio C Hamano wrote:
Show 6 quoted lines
> Johannes Schindelin <Johannes.Schindelin@gmx.de> writes: > > > Anyway, I'm fine with having them only in my personal fork. > > It will cost you some "trust point" next time you try to sneak something > in as a part of a largely unrelated topic. Please don't.
Fine. Fine!
I thought it made the code more readable, and that it also might have helped other sites where you have to strbuf_init() first, and often need curly brackets only because of that. Making for ultra-ugly code.
Please note that I also added a simple test case for the vaddf() function, so your "trying to sneak through" is only half as bad as you made it sound.
Also, please note that the situation with SNPRINTF_RETURNS_BOGUS works, but is a thorn in this developers eye.
Anyway, I will not try to post this patch again, Dscho