Re: What's cooking in git.git (Feb 2026, #03)
- From
Patrick Steinhardt <ps@pks.im>
- Date
- Feb 9, 2026, 09:14 UTC
- Message-ID
- <aYmleK3kGqzLXyJe@pks.im>
- In-Reply-To
- <xmqq7bsob0wo.fsf@gitster.g>
On Sat, Feb 07, 2026 at 03:15:51PM -0800, Junio C Hamano wrote:
Show 9 quoted lines
> * yt/merge-file-outside-a-repository (2026-02-05) 1 commit > - merge-file: honor merge.conflictStyle outside of a repository > > "git merge-file" can be run outside a repository, but it ignored > all configuration, even the per-user ones. The command now uses > available configuration files to find its customization. > > Will merge to 'next'? > source: <D514F3BA-36DD-4DAD-BF73-609730390A27@ytausch.de>
This patch looks good to me.
Show 8 quoted lines
> * ps/meson-gitk-git-gui (2026-02-04) 1 commit > - meson: wire up gitk and git-gui > > Plumb gitk/git-gui build and install procedure in meson based > builds. > > Expecting a reroll. > source: <20260204-b4-pks-meson-tcl-tk-v2-1-5bc3ccf3a8ce@pks.im>
Probably makes more sense to say that this is waiting on a pull request of gitk, as the patch series itself doesn't need to change.
Show 11 quoted lines
> * jc/checkout-switch-restore (2026-01-29) 2 commits > - checkout: tell "parse_remote_branch" which command is calling it > - checkout: pass program-readable token to unified "main" > > "git switch <name>", in an attempt to create a local branch <name> > after a remote tracking branch of the same name gave an advise > message to disambiguate using "git checkout", which has been > updated to use "git switch". > > Comments? > source: <20260129190616.645471-1-gitster@pobox.com>
I think this is a good change, and I'm happy with the current layout. I had the tiniest nit on the first patch, but really don't think the series needs a reroll because of it.
Show 11 quoted lines
> * ps/for-each-ref-in-fixes (2026-02-05) 4 commits > - bisect: simplify string_list memory handling > - bisect: fix misuse of `refs_for_each_ref_in()` > - pack-bitmap: fix bug with exact ref match in "pack.preferBitmapTips" > - pack-bitmap: deduplicate logic to iterate over preferred bitmap tips > > A handful of places used refs_for_each_ref_in() API incorrectly, > which has been corrected. > > Will merge to 'next'? > source: <20260206-b4-pks-fix-for-each-ref-in-misuse-v3-0-1e050c3d6a50@pks.im>
I expect it's ready, but I'd like to wait for Taylor to have a final look before we merge it down.
Show 10 quoted lines
> * ps/object-info-bits-cleanup (2026-01-26) 3 commits > - odb: drop gaps in object info flag values > - builtin/fsck: fix flags passed to `odb_has_object()` > - builtin/backfill: fix flags passed to `odb_has_object()` > > A couple of bugs in use of flag bits around odb API has been > corrected, and the flag bits reordered. > > Comments? > source: <20260126-b4-pks-read-object-info-flags-v1-0-e682a003b17c@pks.im>
I'm pulling in some reviewers to move the series forward.
Patrick